FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » search forums error (cannot search forums)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
search forums error [message #162533] Fri, 04 June 2010 16:30 Go to next message
lbrigman124 is currently offline  lbrigman124   United States
Messages: 26
Registered: March 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have a large message in the forums and I am running 3.0.1.

When I search for anything I get the following message:

Fatal error: Call to undefined function mb_substr() in
/var/www/html/forums/theme/default/search.php on line 1165

My searching does not find the function. Is this something
that was implement in development but didn't get pushed
to the released versions?

Re: search forums error [message #162534 is a reply to message #162533] Fri, 04 June 2010 17:00 Go to previous messageGo to next message
lbrigman124 is currently offline  lbrigman124   United States
Messages: 26
Registered: March 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
It seems that posting a large message also breaks the search.
Even the topic search on my instance is broken.
I have a number as part of the topic. If I search on that it fails.
Re: search forums error [message #162535 is a reply to message #162534] Sat, 05 June 2010 02:35 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Google to the rescue: You need to install or recompile PHP with mb_string support.

I didn't realize that you can still get PHP without it. Running a very old release maybe?
Re: search forums error [message #162536 is a reply to message #162535] Sat, 05 June 2010 02:58 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
http://www.php.net/manual/en/mbstring.installation.php
mbstring is a non-default extension. This means it is not enabled by default. You must explicitly enable the module with the configure option. See the Install section for details.


You're right! We need to double up the code to cater for both or explicitly tell people that they need mb_string support.
Re: search forums error [message #162537 is a reply to message #162535] Sun, 06 June 2010 01:35 Go to previous messageGo to next message
lbrigman124 is currently offline  lbrigman124   
Messages: 26
Registered: March 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Not that old.
PHP 5.1.6 (cli) (built: Jan 4 2010 10:45:55)
Re: search forums error [message #162538 is a reply to message #162537] Sun, 06 June 2010 01:37 Go to previous message
lbrigman124 is currently offline  lbrigman124   
Messages: 26
Registered: March 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Turns out I only needed to install the php-mbstring rpm.

I want a better list of dependencies.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: New registrations - login name - first letter gets drop
Next Topic: post message fails
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Oct 20 23:19:05 EDT 2017

Total time taken to generate the page: 0.00709 seconds