FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » email list not getting messages
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
email list not getting messages [message #162819] Wed, 21 July 2010 22:29 Go to next message
wittrs is currently offline  wittrs   United States
Messages: 134
Registered: August 2009
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I'm having a strange problem. If someone posts at the message board, it isn't getting mailed to the email group. Here is what I have done to trouble shoot:

1. the board IS mailing confirmation messages.
2. I changed the email address on one of the rules. It would not mail to that address either (at least not yet -- is there a delay?).
3. I occasionally receive notifications of board postings, because I am subscribed. But I notice that I do not get some notifications. Recently, several mails were posted that neither went to the email group or were noticed (to me).

What should I do next to investigate this problem?

Thanks in advance
Re: email list not getting messages [message #162820 is a reply to message #162819] Thu, 22 July 2010 00:39 Go to previous messageGo to next message
wittrs is currently offline  wittrs   United States
Messages: 134
Registered: August 2009
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
... just a quick update. I found a "jobs" section on the administrative control panel. It shows all of the maillist rules that I have created for the discussion board. I noticed that when I press "log files" it tells me that "no file is found."

I'm wondering if this has anything to do with anything. I'm running my "jobs" from a crontab, every 15 minutes. There does not seem to be anything wrong with that. Also, the crontab only pipes mail into the forum. My concern is that it is not emailing at the moment. So don't know if these log files would have helped me in my detective work or not. Maybe it is a red herring.

Sorry to perhaps send irrelevant information. (I wasn't sure if I should pass this along. I just thought when the "log file couldn't be found," that I should perhaps tell you about it).

Re: email list not getting messages [message #162821 is a reply to message #162820] Thu, 22 July 2010 02:43 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3628
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Please check errors/.mlist/error_log (as per documentation).

Ensure you write the cron errors somewhere. For example, append this to the crontab line:
>>/tmp/mail.log 2>&1

PS: You can ignore the Jobs ACP. If you don't use it, it won't create a log.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Regular Expression Problem -- "No Message Body"
Next Topic: My board is down
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 11 08:33:54 EST 2017

Total time taken to generate the page: 0.00640 seconds