FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » 2.3.7 Forum issues  () 1 Vote
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
2.3.7 Forum issues [message #163058] Tue, 21 September 2010 15:12 Go to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
First post so I hope this is in the correct place.

I recently purchased a forum which has not been updated since 2002. It is running 2.3.7.

I am in the process of moving it and updating to something that was coded after Justin Bieber was born. I have both a sql dump and a dump from FUDforum. Issue is finding something to import this into. I installed a clean copy of 2.6x which was the oldest version I could find and it would not import a 2.3 dump. Any suggestions?
Re: 2.3.7 Forum issues [message #163061 is a reply to message #163058] Tue, 21 September 2010 16:01 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The 2.3.7 installer is now available on SourceForge at https://sourceforge.net/projects/fudforum/files.

Please install it and use the ACP to import your forum dump.

Once you have a working forum you can download the FUDforum 3.0.0 UPGRADE script to upgrade your forum.

Best of luck!

Frank
Re: 2.3.7 Forum issues [message #163062 is a reply to message #163061] Tue, 21 September 2010 19:07 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I thought this error was from using a bad file but after a fresh install of 2.3.7 I get this error on update:

Notice: Undefined index: INCLUDE in /home/s40con/public_html/fud237/upgrade.php(1041) : eval()'d code on line 1

Warning: file_get_contents(core.inc) [function.file-get-contents]: failed to open stream: No such file or directory in /home/s40con/public_html/fud237/upgrade.php on line 1044

Failed to parse GLOBALS.php at "core.inc" correctly


I did some searching and I tried commenting out the line in global.php but that still caused it to spit out an error. Any thoughts? Again thanks a ton. This is my first expereince with FUDforum so some of the way the parsing is done seems strange. Granted this is 10 year old software in this case.....
Re: 2.3.7 Forum issues [message #163063 is a reply to message #163062] Wed, 22 September 2010 00:38 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I went back and checked my install and everything works with the exception of themes and theme management.

Then I went to click theme management to try a rebuild, all I get is a page saying:
Language FATAL ERROR: '/home/s40con/public_html/forum_data//thm/default/i18n/../locale' is not a file in (/home/s40con/public_html/forum/adm), can't open


System Configuration
PHP built On: Linux cust3888a.ipslink.com 2.6.18-194.11.3.el5 #1 SMP Mon Aug 30 16:19:16 EDT 2010 x86_64
MySQL Version: 4.1.22-standard
PHP Version: 5.2.14
Web Server: Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.14
WebServer to PHP interface: apache2handler
Forum Version: 2.3.7
Relavent PHP Settings:
Safe Mode: OFF
Display Errors: OFF
File Uploads: ON
Magic Quotes: OFF
Register Globals: OFF
Output Buffering: ON
Disabled Functions: none
PSpell Support: No
Re: 2.3.7 Forum issues [message #163066 is a reply to message #163063] Wed, 22 September 2010 16:06 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I've tried to install 2.3.7, but was unsuccessful (it's just too old).
Did you actually manage to get the old forum up and running?
Re: 2.3.7 Forum issues [message #163067 is a reply to message #163066] Wed, 22 September 2010 16:10 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Its sorta up and running.
Forums are fine:
http://208.67.212.172/forum/index.php?t=thread&frm_id=19&rid=3029&a mp;S=f62bcd62a79492ced70a832109296674&start=80&count=40
Home still has outdated links as I cannot rebuild the theme:
http://208.67.212.172/forum/index.php?t=index&rid=3029&S=f62bcd62a7 9492ced70a832109296674

Everything is working fine, I just cannot get theme to rebuild or updated to run. Updated says the dB is invalid, themes give me the above error.
Re: 2.3.7 Forum issues [message #163068 is a reply to message #163067] Wed, 22 September 2010 16:15 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you somehow give me access to check it out? A forum admin users should be a good start.
Re: 2.3.7 Forum issues [message #163069 is a reply to message #163068] Wed, 22 September 2010 16:20 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Dropped you an email with the creditials.
Re: 2.3.7 Forum issues [message #163070 is a reply to message #163069] Wed, 22 September 2010 16:24 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Got it, thanks. I'll have a look tomorrow afternoon.

Regards.

Frank
Re: 2.3.7 Forum issues [message #163071 is a reply to message #163070] Wed, 22 September 2010 16:37 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks a ton. For what its worth the same error was on the other server before the move.
Re: 2.3.7 Forum issues [message #163072 is a reply to message #163070] Wed, 22 September 2010 16:39 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I've applied a quick patch to admthemes.php. Please check if you can rebuild the theme.
Re: 2.3.7 Forum issues [message #163073 is a reply to message #163072] Wed, 22 September 2010 16:51 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That seemed to fix it. Even after a rebuild though it is still showing the old domain name. It will not let me create a new theme but every else seems to work with no errors.

Ignore that. Index.php still had an old reference.

[Updated on: Wed, 22 September 2010 16:57]

Report message to a moderator

Re: 2.3.7 Forum issues [message #163076 is a reply to message #163073] Thu, 23 September 2010 10:25 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Everything seems 95% but I have spent all the time I have messing with this Sad. Who do I contact at services for a paid upgrade?
Re: 2.3.7 Forum issues [message #163079 is a reply to message #163076] Thu, 23 September 2010 22:17 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Do you guys still do paid upgrades?
Re: 2.3.7 Forum issues [message #163080 is a reply to message #163079] Fri, 24 September 2010 02:48 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Hi Charles,

If you requirement is to go from one museum piece (2.3.7) to the next (2.6), I would unfortunately not be willing to help. Sorry.

Try to contact Ilia, he might be able to assist you.

Best regards.

Frank
Re: 2.3.7 Forum issues [message #163081 is a reply to message #163080] Fri, 24 September 2010 02:59 Go to previous messageGo to next message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Isnt next jump 2.7.x. That would be fine. From there I can evaluate everything for a while and if everyone likes it upgrade to 3.0.x when I have time
Re: 2.3.7 Forum issues [message #163083 is a reply to message #163081] Fri, 24 September 2010 04:13 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I guess various combinations of ancient release upgrades are possible. I would be wiling to help you upgrade to 3.0.0 and then to 3.0.1 (in one go).
Re: 2.3.7 Forum issues [message #163085 is a reply to message #163083] Fri, 24 September 2010 10:14 Go to previous message
Volvospeed is currently offline  Volvospeed   United States
Messages: 17
Registered: September 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Drop me an email with how much and if you take paypal or credit card. I really appreciate this. I looked for a list of the jumps so I could manually run the sql changes but I could not find the migration paths.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: 500 INTERNAL SERVER ERROR
Next Topic: Upgrade Problem: Fatal error: Allowed memory size of...
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Sep 25 17:14:49 EDT 2018

Total time taken to generate the page: 0.00743 seconds