FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » [SOLVED] ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
[SOLVED] ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163106] Mon, 27 September 2010 22:07 Go to next message
tux99   Switzerland
Messages: 44
Registered: September 2010
Karma: 0
Member
add to buddy list
ignore all messages by this user
Hi,
I found another issue in 3.0.1, I'm trying to retrieve mail from a yahoo.it mail account which has pop3 enabled, but I get the following error:

Connecting to mailbox {pop.mail.yahoo.it:995/POP3/novalidate-cert}INBOX
Can't connect to mailbox: Connection failed to pop-it.mail.vip.ukl.yahoo.com,995: Connection reset by peer

I have verified that the config is correct and I can retrieve mail from this account via POP3/SSL with other clients, for example mpop.

I believe the problem is that there are two methods of POP3 via SSL and FUDforum only supports the less common STARTTLS method (which yahoo doesn't support).

Quote:

POP3 servers can use TLS in one of two modes:

* Immediately
This is known as POP3 tunneled through TLS. The default port for this mode is 995 (pop3s). This is what most servers support, and is often simply called "POP3 with SSL".
* Via the STARTTLS POP3 command
The POP3 session begins normally. The client sends the STLS command when it wishes to begin TLS encryption. The default port for this mode is the default POP3 port: 110 (pop3).

http://mpop.sourceforge.net/doc/mpop.html#Transport-Layer-Security

Would it be possible for FUDforum to also support the "POP3 tunneled through TLS" method?

[Updated on: Tue, 28 September 2010 18:07]

Report message to a moderator

Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163110 is a reply to message #163106] Tue, 28 September 2010 01:49 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes, we definitely should.
I will prepare a patch later today.
Will you be able to help us test it?
Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163111 is a reply to message #163110] Tue, 28 September 2010 01:53 Go to previous messageGo to next message
tux99   Switzerland
Messages: 44
Registered: September 2010
Karma: 0
Member
add to buddy list
ignore all messages by this user
Many thanks. Yes, I will gladly test it, all I need to know is the details to download and install the dev version (svn parameters and anything I need to do after that).
Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163113 is a reply to message #163111] Tue, 28 September 2010 14:11 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Patch committed.
Details @ http://sourceforge.net/apps/trac/fudforum/changeset/5010
Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163114 is a reply to message #163113] Tue, 28 September 2010 17:44 Go to previous messageGo to next message
tux99   Switzerland
Messages: 44
Registered: September 2010
Karma: 0
Member
add to buddy list
ignore all messages by this user
OK, I did a svn checkout to a separate folder and then simply copied the new versions of the 3 changed files (maillist.php, fud_mlist.tbl, admmlist.php) over the old ones from the 3.0.1 install.

Then (after reconfiguring the ML setup in the FUDforum admin panel) I tested again retrieving ML mail from the previously mentioned yahoo.it mailbox using SSL and this time it worked great!

Here is the (shortened) log output just for reference:

Connecting to mailbox {pop.mail.yahoo.it:995/POP3/ssl/novalidate-cert}INBOX
Loading message 6 Done. Deleting message.
Loading message 1 Done. Deleting message.
Loading message 2 Done. Deleting message.
Loading message 3 Done. Deleting message.
Loading message 4 Done. Deleting message.
Loading message 5 Done. Deleting message.
Loading message 7 Done. Deleting message.
[...]
Loading message 64 Done. Deleting message.
Loading message 65 Done. Deleting message.
Loading message 67 Done. Deleting message.
Loading message 68 Done. Deleting message.
No more mails to process.


Many thanks again for fixing this so quickly!

[Updated on: Tue, 28 September 2010 17:45]

Report message to a moderator

Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163119 is a reply to message #163114] Wed, 29 September 2010 01:11 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Thanks for the feedback!
This is great news and definitely a step in the right direction.

PS: Strange that message 6 is loaded before 1???
Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163122 is a reply to message #163119] Wed, 29 September 2010 02:01 Go to previous messageGo to next message
tux99   Switzerland
Messages: 44
Registered: September 2010
Karma: 0
Member
add to buddy list
ignore all messages by this user
naudefj wrote on Wed, 29 September 2010 07:11

PS: Strange that message 6 is loaded before 1???


Hmm, yes that's weird, I just ran it again to pick up new messages and again the order is random:

Connecting to mailbox {pop.mail.yahoo.it:995/POP3/ssl/novalidate-cert}INBOX
Loading message 1 Done. Deleting message.
Loading message 4 Done. Deleting message.
Loading message 2 Done. Deleting message.
Loading message 3 Done. Deleting message.
Loading message 5 Done. Deleting message.
Loading message 6 Done. Deleting message.
Loading message 7 Done. Deleting message.
No more mails to process. 


It doesn't seem to affect anything though (all messages appear in the correct threads and order on the forum), so I'm not concerned about it.

[Updated on: Wed, 29 September 2010 02:02]

Report message to a moderator

Re : Re: ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode [message #163298 is a reply to message #163122] Fri, 15 October 2010 04:30 Go to previous message
herve is currently offline  herve   France
Messages: 22
Registered: October 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thank you very much for this update. Thanks to you, I just succeeded to connect to my Gmail account using POP3/SSL mode and to import the archives of my mailing-list (almost 2,500 messages) !!! FUDforum is so great !!!
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Trying to register user gives blank page
Next Topic: posting problem
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Dec 15 20:33:03 EST 2017

Total time taken to generate the page: 0.00847 seconds