FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Trying to register user gives blank page
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Trying to register user gives blank page [message #163274] Wed, 13 October 2010 13:42 Go to next message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
PHP Fatal error:  Call to a member function add_user() on a non-object in /home/www/www.rift-news.com/htdocs/theme/Rift_News/register.php on  line 2299 , referer: http://www.rift-news.com/index.php/re/0/


When trying to add a new user the user is presented with a blank screen and the registration never goes through.

Can reg users from the admin interface, forum functions normally other than that.

Running 3.0.1 - It worked earlier today, then just suddenly stopped working, totally clueless to what has broken.

Have restared apache/mysql, ran forum consist/sql opti.


Aw: Trying to register user gives blank page [message #163277 is a reply to message #163274] Wed, 13 October 2010 14:15 Go to previous messageGo to next message
Takyn is currently offline  Takyn
Messages: 1
Registered: October 2010
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am the admin of the page in the OP. Ernesto made this post for me while I was panicking and trying to fix it. Wink

It seems that disabling the botscout plugin has fixed it for now, not entirely sure it was the sole culprit though.
Re: Trying to register user gives blank page [message #163278 is a reply to message #163274] Wed, 13 October 2010 14:43 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Sounds like $uent isn't instantiated (or gets destroyed) before $uent->add_user().

BTW: I just registered on your site and it worked!?!
Re: Trying to register user gives blank page [message #163279 is a reply to message #163278] Wed, 13 October 2010 14:52 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
OK, so we need to focus on the botscout plugin. Can you please add the below echo to see if botscout returns an error:

if (substr($botscout_data, 0, 1) == '!') {	// exclamation mark indicates an error
+		echo "Botscout returned error: ". $botscout_data ."<br />";
		return;


Re: Trying to register user gives blank page [message #163280 is a reply to message #163279] Wed, 13 October 2010 15:01 Go to previous message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Some form of raffle for some game beta keys atm, so can't test it until tomorrow morning when there are few people awake.

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Search results blank...sometimes??
Next Topic: [SOLVED] ML POP3 with SSL retrieval lacks "POP3 tunneled through TLS" mode
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 20:22:08 EDT 2017

Total time taken to generate the page: 0.00725 seconds