FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » Importing forum data 2.7.7 to 3.0
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Importing forum data 2.7.7 to 3.0 [message #163662] Mon, 22 November 2010 08:45 Go to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
Quick Overview: Back in early 2008 I attempted to move my forum data to new free hosting. I was running 2.7.7 in production and in preparation for that I got 2.7.7 installed at new, I ran the backup of production site ok, however everytime I tried to import my forum data it would time out and ultimately corrupt the entire forum with an HTTP 500 error meaning a reinstall of forum from ground up was necessary. I posted about it a couple of times but then gave up.

I was hoping as newer versions of the forum came out the import issue would go away.

FF to today: our forum is now down and I am trying to get it onto current platform of 3.0.2.

Frank you answered my question in the 3.02 announcement area but I am not sure I like the answer you gave as I am thinking I am going to be stuck again with the above error by having to work with 2.7.7.

Quote:
You need to download 2.7.7, import your backup, upgrade to 3.0.0, and then upgrade to 3.0.2.
Key points:
- you need to restore to the version you've backed-up.
- FUDforum 2.x releases must first be upgraded to 3.0.0 before it can be upgraded to the latest release.


Curious as to why V3.x would not be able to import from ver 2.x forums? Will any of the revisional versions of 2.X work that are higher than 2.7.7 import the data, or am I stuck trying to troubleshoot this again in 2.7.7?

Because of the 3rd party hosting I have minimal access and control over the db environment, so probably can't even see log files on the db server which could make troubleshooting tough.

Suggestions??


[Updated on: Mon, 22 November 2010 08:51]

Report message to a moderator

Re: Importing forum data 2.7.7 to 3.0 [message #163666 is a reply to message #163662] Mon, 22 November 2010 11:17 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Backup/restore will only work if the version numbers are 100% the same.
Hence, a 2.7.7 dump can only be restored back to 2.7.7.
This is even documented at Import forum data.
Re: Importing forum data 2.7.7 to 3.0 [message #163668 is a reply to message #163666] Mon, 22 November 2010 12:23 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
naudefj wrote on Mon, 22 November 2010 11:17
Backup/restore will only work if the version numbers are 100% the same.
Hence, a 2.7.7 dump can only be restored back to 2.7.7.
This is even documented at Import forum data.


Thanks for the quick response Frank and link to the import section of the Wiki. The command line options may help.

Ok looks like I need to concentrate on getting it to work 2.7.7. Twisted Evil
Re: Importing forum data 2.7.7 to 3.0 [message #163669 is a reply to message #163668] Mon, 22 November 2010 12:39 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
Thinking aloud of a plan in a different way here:

If I use the prebuilt FUD appliance 2.7.7 on a local PC I get rid of the uncertainty around permissions to the database, no access to logging files etc., then import my data successfully to it using local PC, then follow all the upgrade steps to 3.02 and run a backup file successfully.

Next step try to get 3.02 installed at my ISP/hosting and do an import from 3.02 to 3.02...what do you think any easier?? Will there be compatibility in the databases and file structure if my local PC that I load the appliance on is Windows based?
Re: Importing forum data 2.7.7 to 3.0 [message #163671 is a reply to message #163669] Mon, 22 November 2010 17:06 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
I'm not aware of any prebuilt FUDforum appliance for version 2.7.7.
Importing/ exporting between Windows and Linux should work (although I haven't tested it).
Re: Importing forum data 2.7.7 to 3.0 [message #163732 is a reply to message #163671] Sun, 28 November 2010 15:44 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   Canada
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
I am beginning this process, couple of db specific questions:

I believe that my forum was running on MySQL4. It is not possible to check as it is no longer accessible. Is it possible to import/restore this to a MySQLV5 db, or is it better to start at V4 and convert to V5 with one of the upgrades??

2nd the SQL Table Prefix structure in screen 2 of the 2.7.7 install.php shows that it will start with fud26_, is this just an oversite in the original programming and does it matter? When you perform an upgrade is the SQL prefix incremented automatically? Is there any way to confirm that my backup version is 2.7.7 ?? Or is it possible it is 2.6.x??

Similarly is there any way to tell what version of forum and MySQL was in place from looking at the contents of backup.fud file?

What does the .fud backup file contain? Does it contain the database as well as all the message base, forum structure, css, images etc.??

If I am successful at restoring the .fud file into 2.7.7 then do I need to do each successive release, ie 2.8, 2.9 etc or can I just go to 3.0??

Thank you.
Re: Importing forum data 2.7.7 to 3.0 [message #163733 is a reply to message #163732] Sun, 28 November 2010 21:32 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
MySQLv5 should work just fine. Although, I haven't tested it myself.

The prefix and other settings will be imported from the backup file.

The dump file should be readable. If not, just gunzip it. Even if the import script fails, you should be able to manually recover your files and data from the dump file.

As explained before, the upgrade path is straight to FUDforum 3.0.0 and then straight to 3.0.2 (latest release).

Best of luck. You're going to need it!
Re: Importing forum data 2.7.7 to 3.0 [message #163734 is a reply to message #163733] Sun, 28 November 2010 21:54 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   Canada
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
LOL Thanks, got it installed, starting the import now and will see what happens Rolling Eyes Cool
Re: Importing forum data 2.7.7 to 3.0 [message #163735 is a reply to message #163734] Sun, 28 November 2010 22:09 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   Canada
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
That was quick. Here is what it said, not a huge SQL guy but seems it can't find a table. I looked in phpadmin and they were all there before the import.

As previously when I stalled out trying this 2 years ago it also currupts the forum and if you try to Return to Forum from admin console or to browse to it you get an HTTP500 error Confused


/services9/webpages/f/o/forums.tfbm.org/277forum/include/theme/default/db.i nc:72
/services9/webpages/f/o/forums.tfbm.org/277forum/include/theme/default/db.i nc:132
/services9/webpages/f/o/forums.tfbm.org/public/OLDforum/adm/admimport.php:2 23
) 1146: Table 'old_fud_forums_tfbm_org.fud26_users' doesn't exist
Query: SELECT id FROM fud26_users WHERE login='admin' AND users_opt>=1048576 AND (users_opt & 1048576) > 0
_POST: array ( 'S' => 'df4e5c495f14aeac15694a0123d99d57', 'SQ' => '7ad834158282020ac758389cfb54febb', 'path' => '/tmp', 'btn_submit' => 'Import Data', )
Server Version: 4.0.27-standard
[Referring Page] http://forums.tfbm.org/OLDforum/adm/admimport.php

Edit: and it kills all the tables in the db. The fud26_users was there prior to attempting the import.

[Updated on: Sun, 28 November 2010 22:12]

Report message to a moderator

Re: Importing forum data 2.7.7 to 3.0 [message #163746 is a reply to message #163735] Mon, 29 November 2010 08:54 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
The import script drops all the database tables and recreates them.
I cannot say why the users table wasn't imported (your dump may be incomplete?).
You will have to debug the script to find out what's going on.
Re: Importing forum data 2.7.7 to 3.0 [message #163749 is a reply to message #163746] Mon, 29 November 2010 09:27 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
naudefj wrote on Mon, 29 November 2010 08:54
The import script drops all the database tables and recreates them.
I cannot say why the users table wasn't imported (your dump may be incomplete?).
You will have to debug the script to find out what's going on.


Makes sense it drops the tables first.

I have previously tried the fud import many times with different dumps and never got it to work.

As for debugging the script, I don't think I would know where to begin, I know nothing of php programming...and its fuds script.

How can I view separate sections of the fud file, I have opened the gz archive and only see one big file thats 155 mgs. In trying to view it it just seems to be mass of script code, is there any organization to it??
Re: Importing forum data 2.7.7 to 3.0 [message #163750 is a reply to message #163733] Mon, 29 November 2010 09:31 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
naudefj wrote:
The dump file should be readable. If not, just gunzip it. Even if the import script fails, you should be able to manually recover your files and data from the dump file.


Gunzip it and check for yourself.
Re: Importing forum data 2.7.7 to 3.0 [message #163751 is a reply to message #163750] Mon, 29 November 2010 10:42 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ok I ran 7-Zip on it (which says it understands gunzip).

Not to be a PITA but I now have one 142 mg file that nothing knows how to open. Using Wordpad I can browse it and see a lot of script and SQL commands, and there is user messege data but I am unsure how to go about inserting it manually. Hmm.


Different item here: I found an old screen shot of the forum System Info it shows 2.6RC3, so I wondering if maybe we never got upgraded to 2.7.7 successfully and were still on 2.6. Since you said import must be for exact version, next question is can I get my hands on a 2.6RC3 install archive to try??

Edit: I looked in the Download link on Sourceforge, there is old 2.6 forum installs...why are there so many versions?

Still trying to determine if there is a marker in the backup file that IDs the forum version 100%.

[Updated on: Mon, 29 November 2010 10:46]

Report message to a moderator

Re: Importing forum data 2.7.7 to 3.0 [message #163765 is a reply to message #163751] Mon, 29 November 2010 21:43 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
BAD35th wrote:
Still trying to determine if there is a marker in the backup file that IDs the forum version 100%.

In fact, there is. Open the unzipped dump and search for '$FORUM_VERSION = '.
Re: Importing forum data 2.7.7 to 3.0 [message #163774 is a reply to message #163765] Tue, 30 November 2010 07:39 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
naudefj wrote on Mon, 29 November 2010 21:43
BAD35th wrote:
Still trying to determine if there is a marker in the backup file that IDs the forum version 100%.

In fact, there is. Open the unzipped dump and search for '$FORUM_VERSION = '.


Perfect. Thank you.

Well it says 2.7.7. Which is too bad in a way as it would have been nice to find the problem with importing was because it was the wrong forum version, which could have been an easy fix.

Now we are left with the bigger problem of how to troubleshoot why that import script is always failing Confused

Whats next??
Re: Importing forum data 2.7.7 to 3.0 [message #163776 is a reply to message #163774] Tue, 30 November 2010 12:24 Go to previous messageGo to next message
Ernesto is currently offline  Ernesto   Sweden
Messages: 413
Registered: August 2005
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
After you did the forum datadump, did you download it locally and then upload it again to have it imported?

Re: Importing forum data 2.7.7 to 3.0 [message #163777 is a reply to message #163776] Tue, 30 November 2010 12:28 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ernesto wrote on Tue, 30 November 2010 12:24
After you did the forum datadump, did you download it locally and then upload it again to have it imported?


Yes, I downloaded it to my PC.

It is now going to totally different hosting. I FTP'd it using binary option as it was a gz archive. Do you think it is curropt in some way?? I checked the integrity of the archive and it says it is fine.

EDIT: checked your link, see that you are a guild. I'm on WOW myself, which is why I only have one week to get this operational before Cataclysym ships!! Surprised

[Updated on: Tue, 30 November 2010 12:32]

Report message to a moderator

Re: Importing forum data 2.7.7 to 3.0 [message #163778 is a reply to message #163777] Tue, 30 November 2010 17:35 Go to previous messageGo to next message
BAD35th is currently offline  BAD35th   Canada
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ok I may have found an answer right here (thanks Google!).

Seems like the import code was buggy way back in 06 too, but this guy got it to go with some changes.

http://fudforum.org/forum/index.php?t=msg&goto=34867&#msg_34867


Now can someone walk me thru how I would use Command Line mode on my webhosting site?? Is this where you need an SSH client?? What directory would I run it from??


EDIT: Found quite a nice Windows based SSH terminal called PenguiNet here: www.siliconcircus.com

Found the file admimport.php in the adm folder

So I took out the comment on: define('recovery_mode', 1);

And changed the path in multiple locations in the file from this:
$_POST['path'];

To:
$_POST['/tmp']; - Which is where my fud.gz backup file is located

Now it says run the script as follows:

$ php -q admimport.php

BUT when I try, it comes back and says command not found for php. Where did I go wrong??

EDITEDIT:

Found out the forum hosting does not permit php scripts to be run from SSH shell Confused So they suggest either use path in browser or replicate entire environment to linux PC, run the commands locally and then upload the imported forum. At least I have a road map to try to get this going.

Also they said I could edit the maxtimeout parameter of the HTAaccess file which may help.

Does the running it in browser method sound like it will work??


[Updated on: Tue, 30 November 2010 20:28]

Report message to a moderator

Re: Importing forum data 2.7.7 to 3.0 [message #163795 is a reply to message #163778] Wed, 01 December 2010 11:50 Go to previous message
BAD35th is currently offline  BAD35th   United States
Messages: 61
Registered: February 2007
Location: Hammertown
Karma: 0
Member
add to buddy list
ignore all messages by this user
The Browser method doesn't appear to be working even with the modified script and longer timeout on the .htaccess file. So going to try a local linux install, run the import then upload teh whole thing to the webservices.

Hoping Ubuntu will work with FUD??

I started a separate thread on that question here:

http://fudforum.org/forum/index.php?t=msg&goto=163794&#msg_163794

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Ubuntu and FUD ??
Next Topic: Adding Google AdSense?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 24 03:56:49 EDT 2017

Total time taken to generate the page: 0.01036 seconds