FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Misstype in /scripts/fudapi.inc.php
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Misstype in /scripts/fudapi.inc.php [message #163773] Tue, 30 November 2010 06:02 Go to next message
KVentz is currently offline  KVentz   Russian Federation
Messages: 65
Registered: November 2002
Location: Moscow, Russia
Karma: 0
Member
add to buddy list
ignore all messages by this user
Using fudapi.inc.php in FUDforum 3.0.2 generates fatal syntax error.
Line 593:
			$err = 'value for '. $v .' must be unique, specified value of '. $vals[$v] '. already exists.';

should look like
			$err = 'value for '. $v .' must be unique, specified value of '. $vals[$v] .' already exists.';

There is a point in a wrong place: «'. already» instead of «.' already».

In previous versions this string looked like this:
			$err = "value for {$v} must be unique, specified value of {$vals[$v]} already exists.";
Re: Misstype in /scripts/fudapi.inc.php [message #163775 is a reply to message #163773] Tue, 30 November 2010 11:59 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3631
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Good catch! I'll fix it immediately.

BTW: Thanks for posting the only message today that doesn't contain a complaint nor a demand for support.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: The Smilies, List of active users
Next Topic: Forum Statistics in 3.02
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 11 14:17:35 EST 2017

Total time taken to generate the page: 0.00679 seconds