FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » external_fud_login (fud30_ses table user_id column filled with random numbers)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
external_fud_login [message #164776] Tue, 08 March 2011 05:52 Go to next message
wozzo is currently offline  wozzo   Japan
Messages: 2
Registered: March 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I've been trying to use the external_fud_login function to log users in, but the data in the cookie corresponds to an entry in the 'fud30_ses' table with a user_id which doesn't exist. Most of the entries in the table are 10 digit numbers which definitely aren't in the users table.
The function does sometimes work and provide a cookie corresponding to the correct user, but it seems to be less than 50% of the time.
Anyone know what's going on?
Re: external_fud_login [message #164782 is a reply to message #164776] Tue, 08 March 2011 12:08 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Users with looooong ses.user_id numbers are anonymous users.
They won't have matching entries in the users table.
Re: external_fud_login [message #164789 is a reply to message #164782] Tue, 08 March 2011 20:49 Go to previous message
wozzo is currently offline  wozzo   
Messages: 2
Registered: March 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
ok thanks. I've done some more digging and it looks like the external_fud_login function isn't the problem.

I currently have a page called login.php which is calling the above function and when I go to another page in my site that views the cookie even if it doesn't do anything FUD based with it and I then go to the Forum it seems to work fine.
However if I go directly from my login page to the FUDforum index.php then I get logged in as an anonymous user.
Any explanation as to why this is happening / ways to get around it?
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Gmail problem
Next Topic: message counter off
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 04:17:33 EDT 2017

Total time taken to generate the page: 0.00744 seconds