FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Plugins and Code Hacks » Problem with fudapi.inc.php (Error trying to include the file)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problem with fudapi.inc.php [message #164905] Sat, 02 April 2011 05:33 Go to next message
Dayo is currently offline  Dayo   Bahrain
Messages: 101
Registered: April 2011
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hi all.

Just discovered a few days ago this after a search for something with mail list integration and managed to sort out the templating and now moved on to doing a Joomla bridge. The bridge is an adaptation of the phpbb one done here: mehdiplugins . com / misc / phpbbjoom . htm which I have used in the past. (can't use links apparently)

My problem is that when I try to include the fudapi file, I get the following a 500 error message with the following in the logs:
unexpected T_CONSTANT_ENCAPSED_STRING in /path/to/FUDforum/scripts/fudapi.inc.php on line 593,


A look at the referenced line leaves me no wiser.

The bit of code where it falls over is ...
...
$engine_path = dirname(__FILE__) . DIRECTORY_SEPARATOR;
require_once($engine_path . 'GLOBALS.php');
require_once($DATA_DIR . 'scripts/forum_login.php');
require_once($DATA_DIR . 'scripts/fudapi.inc.php');
...


The and globals forum login files are loaded ok.

Will appreciate any pointers as I can't go further with this.

Thanks


Re: Problem with fudapi.inc.php [message #164907 is a reply to message #164905] Sat, 02 April 2011 06:15 Go to previous messageGo to next message
Dayo is currently offline  Dayo   Bahrain
Messages: 101
Registered: April 2011
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
OK. Found the error.

fudapi.inc.php has ...
$err = 'value for '. $v .' must be unique, specified value of '. $vals[$v] '. already exists.';

in the offending line.

This is an error and should be ...
$err = 'value for '. $v .' must be unique, specified value of '. $vals[$v] .' already exists.';


I.E.
'. already exists.'
should be
.' already exists.'


Surprised I appear to be the first to have hit this.

[Updated on: Sat, 02 April 2011 06:15]

Report message to a moderator

Re: Problem with fudapi.inc.php [message #164913 is a reply to message #164907] Sat, 02 April 2011 08:33 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3631
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It was reported a while back at
http://fudforum.org/forum/index.php?t=msg&goto=163773&

The problem was introduced with FUDforum 3.0.2 and will be fixed in 3.0.3.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Anonymize Fudforum
Next Topic: Sending to mailing-list with a fixed email address
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 12 01:44:54 EST 2017

Total time taken to generate the page: 0.00729 seconds