FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » SQL Error has occurred...
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
SQL Error has occurred... [message #165064] Wed, 20 April 2011 15:58 Go to next message
anthony783 is currently offline  anthony783   United States
Messages: 11
Registered: March 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am getting periodic "SQL Error has occurred" errors on my forum. I ran the consistency check and table optimizer which has reduced the number of times I"m getting the error but still not totally gone.

Error screenshot is attached.

When I go to core.inc at 219, all I see is the code telling me that there's an error. There is no logging being done:

// ACP may try to catch DB errors, e.g. temp table check in admglobal.php.
throw new Exception($error_msg);
} elseif (defined('forum_debug')) { // Debug mode.
echo '<hr>'. $error_msg .'<hr>';
} else {
trigger_error('SQL Error has occurred, please contact the <a href="mailto:'. $GLOBALS['ADMIN_EMAIL'] .'?subject=SQL%20Error">administrator</a> of the forum and have them review the forum's SQL query log', E_USER_ERROR);


Any ideas on what the issue is or where I can go to find out?
  • Attachment: error.png
    (Size: 28.24KB, Downloaded 250 times)
Re: SQL Error has occurred... [message #165067 is a reply to message #165064] Wed, 20 April 2011 22:04 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
anthony783 wrote:
When I go to core.inc at 219, all I see is the code telling me that there's an error. There is no logging being done:


These errors, in fact, are logged!
You will see them in the Error Log Viewer.

EDIT: If you've enabled the syslog.plugin, check your system's error log.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Failed getting archive size from ta//0700//
Next Topic: GLOBALS.php "Bug"??
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 05:16:22 EST 2017

Total time taken to generate the page: 0.00593 seconds