FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » NNTP Import Subject with Non-Ascii Characters
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
NNTP Import Subject with Non-Ascii Characters [message #165125] Thu, 28 April 2011 07:35 Go to next message
jm2morri is currently offline  jm2morri   
Messages: 225
Registered: January 2009
Location: Stratford, Ontario, Canad...
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
There still seems to be a problem with subjects that have non-ascii characters. E.g.

http://www.eaglecentral.ca/forums/index.php?t=msg&goto=137722&S=2ba c665fd7aef3392e70dde94c5b1157#msg_137722

The subject has a TM symbol in it and when importing FUDForum just gave up I guess. I've had user's complain that german characters don't show up properly in the subject as well, which is probably the same issue.

I can send the original newsgroup to anyone who's interested looking at it. Frank, it's e.sup.e in my normal newsgroups. The groups are sort of off the beaten path and I don't want to attract spammers by posting it here in plain text Smile

Cheers,

James
Re: NNTP Import Subject with Non-Ascii Characters [message #165126 is a reply to message #165125] Thu, 28 April 2011 07:38 Go to previous messageGo to next message
jm2morri is currently offline  jm2morri   
Messages: 225
Registered: January 2009
Location: Stratford, Ontario, Canad...
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Quick update...

That link will now have the right subject--I edited it by hand. It did say "(no subject)" without the quotes.

James.
Re: NNTP Import Subject with Non-Ascii Characters [message #165135 is a reply to message #165126] Mon, 02 May 2011 12:17 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you please send me the message id?
I've imported the group, but cannot find that particular message.
Re: NNTP Import Subject with Non-Ascii Characters [message #165136 is a reply to message #165135] Mon, 02 May 2011 12:50 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Got it. Thanks for the mail. Here is the patch against nntp.php:
@@ -260,7 +260,7 @@
 		}
 
 		fud_wordwrap($msg_post->body);
-		$msg_post->subject = htmlspecialchars(apply_custom_replace($emsg->subject));
+		$msg_post->subject = apply_custom_replace($emsg->subject);
 		if (!strlen($msg_post->subject)) {
 			log_script_error('Blank subject', $emsg->raw_msg);
 			$msg_post->subject = '(no subject)';
Re: NNTP Import Subject with Non-Ascii Characters [message #165138 is a reply to message #165136] Mon, 02 May 2011 13:22 Go to previous messageGo to next message
jm2morri is currently offline  jm2morri   
Messages: 225
Registered: January 2009
Location: Stratford, Ontario, Canad...
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Implemented that fix, see test thread here

http://www.eaglecentral.ca/forums/index.php?t=msg&goto=137833&S=438 90b1c15605d9487de9763ace80280#msg_137833

Initial message was posted through website and it showed in Thunderbird reading the NNTP server directly. The reply was composed in Thunderbird and then imported into the FUDforum. It didn't stall this time (which is an improvement) but it stripped out the TM symbol. The TM symbol is in the subject line in Thunderbird. You can find that in the test forum at the same news server....

James.

James.
Re: NNTP Import Subject with Non-Ascii Characters [message #165142 is a reply to message #165138] Tue, 03 May 2011 00:13 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3632
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Before we continue, please check if you've applied this patch. I may just solve the problem:
http://fudforum.svn.sourceforge.net/viewvc/fudforum/trunk/install/forum_dat a/include/scripts_common.inc?r1=5017&r2=5062
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: GLOBALS.php "Bug"??
Next Topic: version 3.0.2: Call to undefined function logaction
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Dec 13 00:31:06 EST 2017

Total time taken to generate the page: 0.00713 seconds