FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Anonymous user's id must be 1
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
icon5.gif  Anonymous user's id must be 1 [message #165501] Wed, 06 July 2011 18:53 Go to next message
Piki is currently offline  Piki
Messages: 2
Registered: July 2011
Location: USA
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

Hi,
I would like to try out FUDforum. I get through setting up the database and admin user, but I get the following message:

FATAL ERROR: anonymous user's ID must be 1!


This is regardless of if I run the installer from the browser or Linux command line (dropping the tables between each attempt). I have encountered similar issues with other forums, and it was solved by going into the database and setting ID for the user mentioned in the error to the ID mentioned in the error; this doesn't seem to work, and I tried going through all the tables for FUDforum. This normally happens because my webhost uses a strange auto-increment value, the forums required a specific value for a certain user. The database server for my webhost is running MySQL 5.1.50. I am using PHP 5.3.6 and apache 2.2.19. Currently, changing hosts isn't an option to get rid of the auto-increment -- the webhost space is donated to the project I work with (Ark Linux) and none of us have enough money to pay for another one. You get what you pay for, right? Smile


Piki
Re: Anonymous user's id must be 1 [message #165502 is a reply to message #165501] Wed, 06 July 2011 20:19 Go to previous messageGo to next message
Piki is currently offline  Piki
Messages: 2
Registered: July 2011
Location: USA
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

I managed to work around this by opening the install.php file in a text editor and modifying it to insert the correct id, as opposed to not inserting an id for the anonymous user.

Piki
Re: Anonymous user's id must be 1 [message #165504 is a reply to message #165502] Wed, 06 July 2011 22:51 Go to previous message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Good fix!

PS: We've already changed the code for the next release to UPDATE the key to id=1 (if required) right after INSERT.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Post are gone, consistency won't run
Next Topic: fatal error upgrading to 3.02
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Jun 22 18:58:35 EDT 2018

Total time taken to generate the page: 0.00676 seconds