FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » User menu aligns vertically to the left after 3.0.3RC1 upgrade(FIXED)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
User menu aligns vertically to the left after 3.0.3RC1 upgrade(FIXED) [message #165618] Wed, 27 July 2011 13:38 Go to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
After upgrade User menu aligns vertically to the left of screen (see image), this has happened on 3 out of 3 forums I have upgraded, the first two were corrected after rebuilding the themes and refreshing but not piasa.info.

I presume this has something to do with the custom theme and header, which seems to be a consistent issue for me during upgrades. I tend to remove the large bar in the header as well as the cherub leaving just the text.

Any ideas on what causes this?

index.php?t=getfile&id=6170&private=0


"I'm a Witcher, I solve human problems; not always using a sword!"

[Updated on: Thu, 25 August 2011 16:58]

Report message to a moderator

Re: User menu aligns vertically to the left after 3.0.3RC1 upgrade [message #165623 is a reply to message #165618] Thu, 28 July 2011 04:58 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You are using a custom theme with a non-default forum.css.tmpl file. So, you need to update your CSS template with the style elements you need from the default CSS template. In particular, look for the section "/* User Control Panel / Top Level Menu. */".
Re: User menu aligns vertically to the left after 3.0.3RC1 upgrade [message #165624 is a reply to message #165623] Thu, 28 July 2011 07:13 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Well Alrighty then that's better! I knew the CSS controlled the menu alignment (L.R.C.) but was unaware there had been that much change.


I copied this code from the Default CSS and inserted it into piasa's CSS to get the menu back:
/* User Control Panel / Top Level Menu. */
#UserControlPanel {
	float: right;
	width: 100%;
	margin: 5px 0 10px 10px;
}	
#UserControlPanel ul {
	list-style: none;
	float: right;
	padding: 0;
	margin: 0;
	text-align:right;
}
#UserControlPanel li {
	margin: 0 7px 0 0;
	position:relative;
	display: inline;
	white-space: nowrap;
}
#UserControlPanel li a {
	color: #069;
	text-decoration: none;
}


Apparently I need to get the CSS up to snuff with the defaults


"I'm a Witcher, I solve human problems; not always using a sword!"
Re: User menu aligns vertically to the left after 3.0.3RC1 upgrade [message #165628 is a reply to message #165624] Thu, 28 July 2011 12:55 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
You can use the above code from the default CSS template, or experiment with some of the styles at
http://css.maxdesign.com.au/listamatic/
Re: User menu aligns vertically to the left after 3.0.3RC1 upgrade [message #165642 is a reply to message #165628] Fri, 29 July 2011 07:17 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
I appreciate the link though it's over my head, I consider myself lucky if I understand 15% of what the CSS applies to (Though the comment codes do help some).

Aside from the menu having been set vertically to the right; the lower "login" field was also moved to the right and the footer ling to FUDforum.org is gone entirely from 2 of 4 installations after the upgrade, but I don't see those in the CSS.

But I'm not seeing either of those listed in the CSS, were those somehow changed as well?

index.php?t=getfile&id=6171&private=0



NOTE: Image preview not working!


"I'm a Witcher, I solve human problems; not always using a sword!"

[Updated on: Fri, 29 July 2011 07:18]

Report message to a moderator

Re: User menu aligns vertically to the left after 3.0.3RC1 upgrade [message #165656 is a reply to message #165642] Sat, 30 July 2011 16:18 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
To fix the alignment you need to copy the following from the default CSS template:
.fl { float: left; }
.fr { float: right; }

See footer.tmpl for changes you need to apply to your own footer template (powered-by was split into powered-by and copyright messages).
Re: User menu aligns vertically to the left after 3.0.3RC1 upgrade [message #165659 is a reply to message #165656] Sun, 31 July 2011 12:51 Go to previous message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
Ok Managed to get those fixed looks like I will need to do lots of work of those custom themes though.

Although the log in field is now positioned properly, the Log in splash screen still comes up aligned to the left and the top of the image meshes with the Menu though (both instances if this are with custom themes so I imagine it's a similar problem, i believe the Post screen is doing the same thing).




"I'm a Witcher, I solve human problems; not always using a sword!"
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Account Approval fails after upgrade (FIXED)
Next Topic: Is FUD's Newsgroup/NNTP setup RFC 3977 compliant?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 21:11:51 EDT 2017

Total time taken to generate the page: 0.00677 seconds