FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » strftime Warning after 3.0.3RC1 upgrade (FIXED)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
strftime Warning after 3.0.3RC1 upgrade (FIXED) [message #165660] Sun, 31 July 2011 14:37 Go to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
After upgrade and subsequent fixes to custom themes found this error when clicking on I-Spy:

Warning: strftime() expects parameter 2 to be long, string given in /home/User/Domain.name/theme/Theme_name/actions.php on line 221

$last_post = (!$is_a && !$r[12] && empty($limit[$r[11]])) ? 'You do not have appropriate permissions needed to see this topic.' : strftime('%a, %d %B %Y %H:%M', $r[9]).'


Any ideas?



"I'm a Witcher, I solve human problems; not always using a sword!"

[Updated on: Thu, 25 August 2011 16:54]

Report message to a moderator

Re: strftime Warning after 3.0.3RC1 upgrade [message #165678 is a reply to message #165660] Thu, 04 August 2011 02:19 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
I thought I've replied to this before.
Anyway, a patch is available at http://sourceforge.net/apps/trac/fudforum/changeset/5334
It would be great if you can test it for us.
Re: strftime Warning after 3.0.3RC1 upgrade [message #165690 is a reply to message #165678] Thu, 04 August 2011 14:25 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
You did, on 08/02/2011 9:06AAM, Quote:
Compare your actions.tmpl with the default and apply the changes to your custom theme.
When I visited the link yesterday the post was gone though!

When I 1st reported the error it had been reported to me by two different users and I had seen it myself while was correcting the theme and alignment problems (it remained even after consistency check, theme rebuild, dumping cache and cookies and refreshing), since yesterday morning the issue is gone (not even an error message in the log).

I looked at the "actions.tmpl" in the Default theme but was not sure what you meant by "apply the changes to your custom theme" since my custom themes don't have an "actions.tmpl" (the recommendations have always been to copy only necessary files header, CSS, Footer, etc....)

Since you provided a patch I applied it, though I don't know what good it will do since the original error is already gone.

I'll keep an eye open!


"I'm a Witcher, I solve human problems; not always using a sword!"
Re: strftime Warning after 3.0.3RC1 upgrade [message #165693 is a reply to message #165690] Thu, 04 August 2011 15:46 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
I've deleted the first message as it was just plain wrong. However, I thought I've replaced it with a better follow-up. Anyway, as long as everything is working we're OK.
Re: strftime Warning after 3.0.3RC1 upgrade [message #165853 is a reply to message #165693] Wed, 17 August 2011 21:33 Go to previous message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Thu, 04 August 2011 14:46
I've deleted the first message as it was just plain wrong. However, I thought I've replaced it with a better follow-up. Anyway, as long as everything is working we're OK.

You're in luck, that error just popped back up again, as if I didn't have enough problems already.

Uploaded them to /forum_data/thm/default/tmpl and rebuilt themes, the error went away!

Bear with me I'm doing the best I can.



"I'm a Witcher, I solve human problems; not always using a sword!"
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Enhanced captcha's
Next Topic: attribute x-no-archive ?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Oct 18 09:04:28 EDT 2017

Total time taken to generate the page: 0.00801 seconds