FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » I am afraid i have a problem (I get this error when i want to change the forum display order)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
I am afraid i have a problem [message #166457] Tue, 13 December 2011 10:37 Go to next message
hbmmafia is currently offline  hbmmafia
Messages: 11
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
it seems i have a problem.....
Fatal error: Uncaught exception 'Exception' with message '(/home/admin/fudforum1/include/theme/default/db.inc:104<br /> /home/admin/xxxxxxxx.org/test/adm/admforum.php:127<br /> ) 1054: Unknown column 'nameDESC' in 'order clause'<br /> Query: SELECT id FROM fud30_forum WHERE cat_id=1 ORDER BY nameDESC<br /> _GET: array ( 'o' =&gt; '0', 'ot' =&gt; 'name', 'cat_id' =&gt; '1', 'SQ' =&gt; '5d09020aa09d702b71abbc03f5e9d505', )<br /> Database version: 5.0.92<br /> [Referring Page] http://xxxxxxxx.org/test/adm/admforum.php?&amp;SQ=5d09020aa09d702b71abbc03f5e9d505<br /> ' in /home/admin/fudforum1/include/core.inc:256 Stack trace: #0 /home/admin/fudforum1/include/theme/default/db.inc(104): fud_sql_error_handler() #1 /home/admin/xxxxxxx.org/test/adm/admforum.php(127): q('SELECT id FROM ...', 'Unknown column ...', 1054, '5.0.92') #2 {main} thrown in /home/admin/fudforum1/include/core.inc on line 256

Any ideas? ty
Re: I am afraid i have a problem [message #166462 is a reply to message #166457] Wed, 14 December 2011 19:38 Go to previous messageGo to next message
The Witcher is currently offline  The Witcher   United States
Messages: 662
Registered: May 2009
Location: USA
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
To clarify their having an issue with the Forum Management System for reordering the forums briefly discussed here: http://fudforum.org/forum/index.php?t=msg&th=120274&goto=166444& ;#msg_166444


I tried it myself and had the same error.



"I'm a Witcher, I solve human problems; not always using a sword!"
Re: I am afraid i have a problem [message #166463 is a reply to message #166457] Thu, 15 December 2011 06:33 Go to previous messageGo to next message
hbmmafia is currently offline  hbmmafia
Messages: 11
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
does any one have a idea ??? is there a sql querry we have to do or create something in the database to fix this?
Re: I am afraid i have a problem [message #166464 is a reply to message #166463] Thu, 15 December 2011 08:32 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3687
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Fix @ http://fudforum.svn.sourceforge.net/fudforum/?rev=5410&view=rev

EDIT: The diff doesn't show the spaces added on line 127. The patch is:
--- admforum.php	(revision 5350)
+++ admforum.php	(revision 5410)
@@ -124,7 +124,7 @@
 	if (isset($_GET['o'], $_GET['ot'])) {
 		if (in_array($_GET['ot'], array('name', 'descr', 'date_created'))) {
 			$i = 0;
-			$r = q('SELECT id FROM '. $tbl .'forum WHERE cat_id='. $cat_id .' ORDER BY '. $_GET['ot'] . ((int)$_GET['o'] ? 'ASC' : 'DESC'));
+			$r = q('SELECT id FROM '. $tbl .'forum WHERE cat_id='. $cat_id .' ORDER BY '. $_GET['ot'] . ((int)$_GET['o'] ? ' ASC' : ' DESC'));
 			while ($o = db_rowarr($r)) {
 				q('UPDATE '. $tbl .'forum SET view_order='. ++$i .' WHERE id='. $o[0]);
 			}
Re: I am afraid i have a problem [message #166465 is a reply to message #166464] Thu, 15 December 2011 08:49 Go to previous messageGo to next message
hbmmafia is currently offline  hbmmafia
Messages: 11
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
i downloaded the admforum.php but Where is that file located ? please and thank you
Re: I am afraid i have a problem [message #166466 is a reply to message #166465] Thu, 15 December 2011 08:51 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3687
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
In your forum's 'adm' directroy. Search for it.
Re: I am afraid i have a problem [message #166468 is a reply to message #166466] Thu, 15 December 2011 08:53 Go to previous messageGo to next message
hbmmafia is currently offline  hbmmafia
Messages: 11
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
ok i found it lol for some reason my ftp program cant read the folder but filemanager of my control panel can for some reason apache is the owner and not me thanks
Re: I am afraid i have a problem [message #166469 is a reply to message #166468] Thu, 15 December 2011 09:02 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3687
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The easiest is to use the Forum's File Manager to upload files. It will upload as the "apache" user.
Re: I am afraid i have a problem [message #166472 is a reply to message #166469] Thu, 15 December 2011 13:20 Go to previous message
hbmmafia is currently offline  hbmmafia
Messages: 11
Registered: December 2011
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
yes thanks i got it ty
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: No IMAP option in maillist manager
Next Topic: upgrade to 3.03 failed - "an error occurred while processing this directive"
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Dec 12 07:00:46 EST 2018

Total time taken to generate the page: 0.00707 seconds