FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » console install (trying to install any-which-way)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
console install [message #167150] Sat, 05 May 2012 06:59 Go to next message
THUFIR is currently offline  THUFIR
Messages: 21
Registered: May 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm just trying to install fudforum into /var/www on Ubuntu, but can't seem to execute the install script either from the CLI or browser.
  • Attachment: browser.txt
    (Size: 0.17KB, Downloaded 219 times)
  • Attachment: console.txt
    (Size: 1.62KB, Downloaded 203 times)
Re: console install [message #167154 is a reply to message #167150] Sun, 06 May 2012 03:32 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
> Please grant read/write permissions on this installation file () to the web-server user to proceed.

Definitely a bug! I'll fix it in the next release. As workaround: $ chmod 744 install.php

> The required data archive is missing from the installation package. Please rectify this and try again.

The installer looks for a file './fudforum_archive' (current working directory). Workaround is to 'cd' to this directory to run the script. Probably also something we can improve before the next release.
Re: console install [message #167155 is a reply to message #167154] Sun, 06 May 2012 04:24 Go to previous messageGo to next message
THUFIR is currently offline  THUFIR
Messages: 21
Registered: May 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Sun, 06 May 2012 00:32

Definitely a bug! I'll fix it in the next release. As workaround: $ chmod 744 install.php


Ah, thank you for letting me know!

I'm still getting the same error from clicking on that install file from firefox, but I don't know why. Attached is another attempt to install from the console.

Should I be in a different directory?

I fixed the results of the console install, accidentally posted the wrong file.

thank you,

Thufir
  • Attachment: fud.txt
    (Size: 2.09KB, Downloaded 233 times)

[Updated on: Sun, 06 May 2012 04:44]

Report message to a moderator

Re: console install [message #167156 is a reply to message #167155] Sun, 06 May 2012 05:49 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
>I'm still getting the same error from clicking on that install file from firefox, but I don't know why.

Probably because it belongs to root and not the webserver's user?

> Failed to create "/home/lampstack/apache2/htdocs/forum/". Please create it manually and grant read/write permissions to the web-server user (root/root)

You need to find out why FUDforum cannot create the directory. Do you even have "/home/lampstack/apache2/htdocs" created on your system? Why don't you just create it manually?
Re: console install [message #167157 is a reply to message #167156] Sun, 06 May 2012 06:06 Go to previous messageGo to next message
THUFIR is currently offline  THUFIR
Messages: 21
Registered: May 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
naudefj wrote on Sun, 06 May 2012 02:49

> Failed to create "/home/lampstack/apache2/htdocs/forum/". Please create it manually and grant read/write permissions to the web-server user (root/root)



Pardon, I didn't really read that .ini file nor the error very closely. While the GUI (firefox browser) install still gives that error, the CLI install seems much better, it's installed, or at least says it is.

However, I can't seem to browse to the URL...?

Muchos Gracias, I'll keep reading and trying stuff.
  • Attachment: fud.txt
    (Size: 2.21KB, Downloaded 227 times)

[Updated on: Sun, 06 May 2012 06:19]

Report message to a moderator

Re: console install [message #167158 is a reply to message #167157] Sun, 06 May 2012 06:19 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3654
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
> 1049: Unknown database 'fudforum' @ Opening MasterDB fudforum

The easiest would be to use phpMyAdmin to create a database. You can also do it from command line, just don't ask me for the syntax.

PS: I would rather get the web installer going, command line works well, but you install from root and intend to run from the web server user. This may require a lot of manual chmod/chown's to get it going.
Re: console install [message #167159 is a reply to message #167158] Sun, 06 May 2012 06:44 Go to previous message
THUFIR is currently offline  THUFIR
Messages: 21
Registered: May 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok, I got to the welcome page! thank you for the help here, and thank you to ari_stress on irc. It was a permissions problem as attached.

As I'm on Ubuntu, install.php needed to belong to group www-data apparently. Ok, I think I'll consider this thread closed successfully Smile
  • Attachment: welcome.txt
    (Size: 0.57KB, Downloaded 248 times)

[Updated on: Sun, 06 May 2012 08:28]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Upgrade to 3.0.4
Next Topic: FQDN causes login failure
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Jun 21 06:44:10 EDT 2018

Total time taken to generate the page: 0.00750 seconds