FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Synchronize to mailing list not sending anything to list (Synchronize to mailing list not sending anything to list)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Synchronize to mailing list not sending anything to list [message #167386] Wed, 13 June 2012 14:49 Go to next message
deadesq is currently offline  deadesq
Messages: 4
Registered: June 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm returning to FUDForum after a couple years away, and I'm impressed at the progress that has been made on it since the 2.x version I originally was trying to set up. But I'm stymied by an issue right now.

We have a Mailman list that I'm trying to synchronize with FUDForum. I currently have a phpBB2 board doing this, but the forum software is so outdated with phpBB2, I'm tired of maintaining it and dealing with spammers on the board. So, I'm trying to go back to FUDForum. The importation is working fine with an IMAP mailbox that is a member on the Mailman list, but posts directly on the FUDForum board are not going back to the Mailman list. I can't get any error messages, and the cron job is importing correctly. Do I need to schedule a cron job of some kind to run an out-going mail, too, or does the option to synchronize to the mailing list take care of that? If so, it's not working, and I'm not sure where to go from here. Any help would be appreciated!

dave
Re: Synchronize to mailing list not sending anything to list [message #167387 is a reply to message #167386] Wed, 13 June 2012 15:08 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3681
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
All you need to do is enable "Synchronize Forum Posts to Mailing List" in the Mailing List Manager. Imported messages (old) will not be mailed out, only new posts made by users on the forum. Check if you get mail related errors in the forum's Error Log Viewer.
Re: Synchronize to mailing list not sending anything to list [message #167388 is a reply to message #167387] Wed, 13 June 2012 15:20 Go to previous messageGo to next message
deadesq is currently offline  deadesq
Messages: 4
Registered: June 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have that option selected, but it's still not sending anything to the list. I've tried with the built-in sendmail, as well as with an external SMTP server. Nothing seems to be going out. I'm not even getting registration confirmation emails from the list.

naudefj wrote on Wed, 13 June 2012 15:08
All you need to do is enable "Synchronize Forum Posts to Mailing List" in the Mailing List Manager. Imported messages (old) will not be mailed out, only new posts made by users on the forum. Check if you get mail related errors in the forum's Error Log Viewer.

Re: Synchronize to mailing list not sending anything to list [message #167392 is a reply to message #167388] Thu, 14 June 2012 01:56 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3681
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can your PHP installation/ system send mail?
Check by implementing a simple mail.php script to e-mail something to yourself.
Re: Synchronize to mailing list not sending anything to list [message #167396 is a reply to message #167392] Thu, 14 June 2012 11:01 Go to previous messageGo to next message
deadesq is currently offline  deadesq   United States
Messages: 4
Registered: June 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That's where I started--a simple sendmail script. That wasn't working, so that's what led me to the issue ultimately. Since others may have it and others may have solved it, I'll describe it a bit. My email is handled through Google Apps, so I have a different MX record for incoming and outgoing mail than my web provider uses. So, when sendmail tries to send, it fails because it is looking for the internal mail function not Google Apps. I don't have access to the hosts file to edit that, so the web provider did a custom php.ini for the sendmail function. It's still not working the way it should, though, so I'm continuing to troubleshoot. I am able to send with the simple sendmail script now, but FUDForum is still not sending correctly. I'll keep plugging away, though.

I have tried setting up the SMTP server, too, in FUDForum, but that's not doing anything, at least with the mailing list manager synchronizing to the Mailman list. I haven't seen if it's sending email otherwise.

Does that make sense?
Re: Synchronize to mailing list not sending anything to list [message #167397 is a reply to message #167396] Thu, 14 June 2012 11:27 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3681
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you tried Google's SMTP server? Enable SMTP, server is smtp.gmail.com, user is your full gmail address and password is your gmail password. This will only work if you enabled "Use SMTP To Send E-mail" in your GMail settings.

This may also help:
http://support.google.com/mail/bin/answer.py?hl=en&answer=78799
Re: Synchronize to mailing list not sending anything to list [message #167398 is a reply to message #167397] Thu, 14 June 2012 11:36 Go to previous message
deadesq is currently offline  deadesq   United States
Messages: 4
Registered: June 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
That was the first thing I tried after I figured out it might be an issue with Google Apps. It did not work. Now--the only place I see to set the SMTP server is in the Global Settings Manager. Is there another place to put SMTP settings so that the Mailing List Manager will send email?
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Import problem at fud30_msg
Next Topic: Mailing List to Forum
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Oct 19 05:38:57 EDT 2018

Total time taken to generate the page: 0.00754 seconds