FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Cache problem when logging in and pressing "Back"
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Cache problem when logging in and pressing "Back" [message #167847] Tue, 23 October 2012 06:01 Go to next message
LeCoyote is currently offline  LeCoyote   France
Messages: 18
Registered: October 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

On our freshly installed 3.0.4.1 setup, we have discovered a reproducible, probably cache-related, bug.

  1. Visit the forum as an unauthenticated user, and navigate to a thread.
  2. Click "Post reply": you are taken to the Login Form.
  3. Log in: you are taken to the Post Form.
  4. Go Back without posting anything: you are now at the Login Form again.
  5. Navigate to the forum home page (note that you are logged in).
  6. Navigate to the thread chosen in 1.
  7. The Quick Reply is unavailable, and clicking the "Post reply" button will take you to a login form, therefore preventing you from replying.


A workaround is to force reload the page without cache (Ctrl+Shift+R).

Reproduced on Mozilla FireFox and Chromium. This bug is not limited to the action of replying to a thread.

Cheers
--
Romain
Re: Cache problem when logging in and pressing "Back" [message #167849 is a reply to message #167847] Wed, 24 October 2012 01:02 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Not sure it can be fixed, since the behaviour is caused by browser caching. Anyway, someone should at least look at this.
Re : Cache problem when logging in and pressing "Back" [message #167864 is a reply to message #167847] Sat, 27 October 2012 09:47 Go to previous message
LeCoyote is currently offline  LeCoyote   France
Messages: 18
Registered: October 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Well, it's actually more serious than that, so it definitely *should* be fixed. It probably can, with cache control.

As described by a user, it is not necessary to press "Back" to demonstrate the problem. Just navigating anywhere else and then trying again to Post/Reply in the same forum or to the same thread as in step 2 will create a problem.

So basically, if a logged out user has the misfortune to click "Post", log in, and try to post more than once, he won't be able to. This is pretty serious.

Cheers
--
Romain

[Updated on: Sun, 09 December 2012 04:49]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Admin links randomly drop back to forum
Next Topic: Serious NNTP Import bug in FUDforum 3.0.3
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 10:15:29 EDT 2017

Total time taken to generate the page: 0.00626 seconds