FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » Imported messages » comp.lang.php » trouble with php5 ( while phpmyadmin works)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
trouble with php5 ( while phpmyadmin works) [message #179421] Thu, 25 October 2012 05:18 Go to next message
abelahcene is currently offline  abelahcene
Messages: 1
Registered: October 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
J have installed php5 with the rest of the tools on debian wheezy LAMP.
the phpmyadmin works properly, suggesting that all tools are properly configured.
I launched localhost/myphpadmin I received the correct page and I connected without problem.

But if I put any command for example the famous phpinfo () in a file tester.php, I place this file in the root /var/www or in a personal directory (I comment out the lines that it must be in the module mod_php to activate the home directory, anyway the problem remains the same in the root)
Php is not executed!!?? if I put this file in the directory of phpmyadmin it runs!!

2 or 3 years ago, I used the same procedure, the php/apache2 worked.

I guess there's a new data in the latest version of php or apache2.

thank you for your help
greetings
bela
Re: trouble with php5 ( while phpmyadmin works) [message #179423 is a reply to message #179421] Thu, 25 October 2012 07:08 Go to previous messageGo to next message
Denis McMahon is currently offline  Denis McMahon
Messages: 634
Registered: September 2010
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
On Thu, 25 Oct 2012 02:18:42 -0700, abelahcene wrote:

> [where is documentroot]

grep -i documentroot /etc/apache2/apache2.conf
grep -i documentroot /etc/apache2/sites-enabled/*

Rgds

Denis McMahon
Re: trouble with php5 ( while phpmyadmin works) [message #179424 is a reply to message #179421] Thu, 25 October 2012 11:31 Go to previous message
M. Strobel is currently offline  M. Strobel
Messages: 386
Registered: December 2011
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Am 25.10.2012 11:18, schrieb abelahcene(at)gmail(dot)com:
> (I comment out the lines that it must be in the module mod_php to activate the home directory, anyway the problem remains the same in the root)
> Php is not executed!!?? if I put this file in the directory of phpmyadmin it runs!!
>

What does this mean exactly about commented lines? If you removed the PHP
configuration, put it back.

What does "Php is not executed" exactly mean? If you see the PHP source in the
browser, it would be clearer to say so.

Does your script habe the necessary <?php tag?

/Str.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: [newbie] Small question about FastCGI
Next Topic: learn php in 17 hour
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Dec 13 02:34:21 EST 2017

Total time taken to generate the page: 0.00692 seconds