FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » [3.0.5] bug with cyrillic subject from usenet
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
[3.0.5] bug with cyrillic subject from usenet [message #183206] Sat, 12 October 2013 10:52 Go to next message
vadim s. sabinich is currently offline  vadim s. sabinich   United States
Messages: 5
Registered: October 2013
Location: Russia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I try use FUDforum for importing/backuping usenet conferences and I see these issues

original article

Path: fidonet.sabini.ch!f279.n5070.z2.fidonet.org!p1.f102.n5080.z2.fidonet.org!fidogate!not-for-mail
<..cut.>
Subject: Самая старая действующая BBS в мире?
<..cut.>
X-Gateway: FIDO fidonet.sabini.ch [FIDOGATE 5.2.4ds]
<..cut.>
X-FTN-Kludge: CHRS: CP866 2
<..cut.>
MIME-Version: 1.0
Content-Type: text/plain; charset=koi8-r
Content-Transfer-Encoding: 8bit
Xref: fidonet.sabini.ch fido7.fidonet.history:125

Hello Dmitriy!

12 Aug 12 10:17, you wrote to All:

 DK> Hello *All* !

 DK> А кто знает, какая из оставшихся в живых BBS самая старая?


so.. and after importing to FUDforum I see, that cyrillic symbols from "subject" is epmty or (if "Subject" was contains only cyrillic symbols - "(no subject)"

If I posting from news-client (Thunderbird, for example) field "subject" contains "Subject: =?UTF-8?B?0JrQoy3QmtCj?=
" and show from FUDforum very well.
Re: [3.0.5] bug with cyrillic subject from usenet [message #183233 is a reply to message #183206] Sun, 13 October 2013 14:29 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Please apply this patch and let us know if it helps:
http://sourceforge.net/p/fudforum/code/5708/
Re: [3.0.5] bug with cyrillic subject from usenet [message #183239 is a reply to message #183233] Sun, 13 October 2013 23:11 Go to previous messageGo to next message
vadim s. sabinich is currently offline  vadim s. sabinich   United States
Messages: 5
Registered: October 2013
Location: Russia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
i applied this patch, removed all posts from one forum, cleared tracker for newsgroup and run task for importing... but nothing changes. all subject with cyrillic symbols has "(no subject)"
Re: [3.0.5] bug with cyrillic subject from usenet [message #183240 is a reply to message #183239] Mon, 14 October 2013 01:44 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Please check if the patch is properly installed, as it really should fix the problem.
If not, attach/mail me a complete message that I can use to simulate the problem.
Re: [3.0.5] bug with cyrillic subject from usenet [message #183241 is a reply to message #183240] Mon, 14 October 2013 03:01 Go to previous messageGo to next message
vadim s. sabinich is currently offline  vadim s. sabinich   United States
Messages: 5
Registered: October 2013
Location: Russia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
i just downloaded new file scripts_common.inc from your link and replaced old file on my forum-data dir. Now i recreated forum and newsgroup' export, but anyway i see "(no subject)". sorry ;-\
Re: [3.0.5] bug with cyrillic subject from usenet [message #183248 is a reply to message #183240] Mon, 14 October 2013 23:40 Go to previous messageGo to next message
vadim s. sabinich is currently offline  vadim s. sabinich   United States
Messages: 5
Registered: October 2013
Location: Russia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
also fudforum eating cyrillic symbols into field "from". (replacing to "_")
Re: [3.0.5] bug with cyrillic subject from usenet [message #183383 is a reply to message #183248] Mon, 21 October 2013 14:54 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
Both these messages are incorrectly encoded. Message headers should only contain ASCII/UTF-8 characters. The 'Content-Type' describes the character encoding of the message body, not the header. Hence, we cannot change the charset of the subject, if we do, we will mess up good messages as well.

Also see http://fudforum.org/forum/index.php?t=msg&th=119545
Re: [3.0.5] bug with cyrillic subject from usenet [message #183395 is a reply to message #183383] Tue, 22 October 2013 03:18 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
I've managed to solve the problem with these hacks:
http://sourceforge.net/p/fudforum/code/5713/
http://sourceforge.net/p/fudforum/code/5715/

Please test and let me know ASAP.
Re: [3.0.5] bug with cyrillic subject from usenet [message #183409 is a reply to message #183395] Wed, 23 October 2013 11:50 Go to previous message
vadim s. sabinich is currently offline  vadim s. sabinich   
Messages: 5
Registered: October 2013
Location: Russia
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
i download trunk 5715 and use it for fresh installation of fudforum.
so...
it really work for me! amazing! thanks! but.. Wink
user "Юрий Григорьев" has transformed to "Юрий Григор". I think, that symbol "ь" was adopted for the technical and delete it and all of the following

http://fidonet.sabini.ch/index.php?t=msg&goto=5747&#msg_5747 for example.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Error with images after upgrade to 3.0.5
Next Topic: Relative Links not working in 3.0.5
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 18:36:30 EDT 2017

Total time taken to generate the page: 0.00761 seconds