FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrade error--3.0.3 to 3.0.5 (gzuncompress error)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrade error--3.0.3 to 3.0.5 [message #183293] Sun, 20 October 2013 00:13 Go to next message
Tikatu is currently offline  Tikatu   United States
Messages: 24
Registered: April 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm trying to upgrade from 3.0.3 to 3.0.5 (and avoid the nightmare of our upgrade from 2.7 to 3.0).

This is the error I got from running the upgrade.php script:

Quote:
Warning: gzuncompress() [function.gzuncompress]: data error in /home/www/irnextphase.tikatu.com/fudforum/upgrade.php on line 302
Archive did not pass the checksum test, it is corrupt!
If you've encountered this error it means that you've:
•downloaded a corrupt archive
•uploaded the archive to your server in ASCII and not BINARY mode
•your FTP Server/Decompression software/Operating System added un-needed cartrige return (' ') characters to the archive, resulting in archive corruption.


So, what does this mean and what can I do to fix it?

Also, what exactly do I need to change in GLOBALS.php and how do I do it?

Thanks in advance!
Re : Upgrade error--3.0.3 to 3.0.5 [message #183299 is a reply to message #183293] Sun, 20 October 2013 04:40 Go to previous messageGo to next message
TheDude is currently offline  TheDude
Messages: 120
Registered: November 2012
Location: France
Karma: 2
Senior Member
add to buddy list
ignore all messages by this user
•uploaded the archive to your server in ASCII and not BINARY mode

This is probably the problem. Use FilleZilla and set the Transfer mode to binary and not Automatic or ASCII.

It happened to me also


Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183318 is a reply to message #183299] Sun, 20 October 2013 12:57 Go to previous messageGo to next message
Tikatu is currently offline  Tikatu   United States
Messages: 24
Registered: April 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks for the answer! I goofed on the first try, but figured out what I did wrong--uploaded the wrong upgrade file. Embarassed Now that I actually have 3.0.5 on my forum, I get this error message:

Quote:
$SERVER_TZ = 'America/New_York'; $DISABLED_REASON = 'Temporarily offline; please come back soon!'; $FUD_OPT_1 = 1737422397;


I have changed the timezone setting to America/New York (which is what it should be) but this error message still shows up after enabling the forum. What can I do to fix that?


ETA: Also, my categories are not showing up. All the forums are listed under "Public Forums".

[Updated on: Sun, 20 October 2013 13:19]

Report message to a moderator

Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183327 is a reply to message #183318] Sun, 20 October 2013 14:14 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3645
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Remember to run the consistency checker after the upgrade as per instructions.
Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183336 is a reply to message #183327] Sun, 20 October 2013 15:17 Go to previous messageGo to next message
Tikatu is currently offline  Tikatu   United States
Messages: 24
Registered: April 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I thought I had. I'll try it again.

ETA: I did it again, and now my categories have returned. However, I still have that error message.

Quote:
$SERVER_TZ = 'America/New_York'; $DISABLED_REASON = 'Temporarily offline; please come back soon!'; $FUD_OPT_1 = 1737422397;

[Updated on: Sun, 20 October 2013 15:20]

Report message to a moderator

Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183340 is a reply to message #183336] Sun, 20 October 2013 15:44 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3645
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Looks like a part of your GLOBALS.php file, not an error. I bet your GLOBALS.php is somehow messed up.
Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183347 is a reply to message #183340] Sun, 20 October 2013 16:10 Go to previous messageGo to next message
Tikatu is currently offline  Tikatu   United States
Messages: 24
Registered: April 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
How so? I can edit it if necessary but I don't know what to edit or where.
Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183361 is a reply to message #183347] Mon, 21 October 2013 01:30 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3645
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Problem fixed.
Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183381 is a reply to message #183361] Mon, 21 October 2013 13:12 Go to previous messageGo to next message
Tikatu is currently offline  Tikatu   United States
Messages: 24
Registered: April 2012
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks so much! I really appreciate it!
Re: Re : Upgrade error--3.0.3 to 3.0.5 [message #183393 is a reply to message #183381] Tue, 22 October 2013 03:11 Go to previous message
naudefj is currently offline  naudefj   
Messages: 3645
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
For future reference, fix is at
http://sourceforge.net/p/fudforum/code/5711/
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Checklist for Internal Server Error problems after installation
Next Topic: Can't connect to MySQL server on '127.0.0.1'
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Apr 25 12:13:45 EDT 2018

Total time taken to generate the page: 0.00782 seconds