FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » upgrade to PHP 5.4 - concern for older version?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
upgrade to PHP 5.4 - concern for older version? [message #183954] Thu, 28 November 2013 20:42 Go to next message
Macavity is currently offline  Macavity   United States
Messages: 5
Registered: November 2013
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am now dealing with a 5-year-old legacy forum running FUDforum version 2.7.7 on Bluehost. Previous attempts at upgrading to a newer version had apparently failed. The forum has been essentially troublefree (max props!) all this time.

Bluehost will be upgrading the account to PHP 5.4 early next week.

Is there any cause for concern in this upgrade? My PHP skills are modest but I do understand the phrase "backwards incompatible"...

Not sure what my options are if the forum breaks.

Thanks.
Re: upgrade to PHP 5.4 - concern for older version? [message #183957 is a reply to message #183954] Thu, 28 November 2013 23:55 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3680
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
FUDforum 2.7.7 is VERY OLD (2007 vintage) and will most likely not work with PHP 5.4! Upgrade path is to FUDforum 3.0.0 and then to 3.0.5 (or even 3.0.6RC1).

Best of luck!
Re: upgrade to PHP 5.4 - concern for older version? [message #183992 is a reply to message #183957] Sat, 30 November 2013 12:49 Go to previous message
Macavity is currently offline  Macavity   United States
Messages: 5
Registered: November 2013
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
So far, so good.

Fingers crossed.

Will be planning to upgrade but good not to have to do it under the gun Wink

-----------

ETA: Version 2.7.7 has been running under PHP 5.4 for over a week without incident now. Just an FYI for any other unfortunates dealing with ancient legacy versions.

[Updated on: Sat, 07 December 2013 11:38]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Problems part 2
Next Topic: $DATA_DIR when installing second FUDforum on server?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Sep 23 18:05:54 EDT 2018

Total time taken to generate the page: 0.00667 seconds