FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Plugins and Code Hacks » Proposed fix to ckeditor.plugin
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Proposed fix to ckeditor.plugin [message #184891] Thu, 13 February 2014 13:43 Go to next message
wferguss   Canada
Messages: 11
Registered: December 2013
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
There is an extra line at the end of the ckeditor.plugin file (after ?>) as included with FUDforum 3.0.5. This causes attachment files to be modified on download (0x0A added to the beginning of the file), such that image files are corrupted and cannot be opened (see http://fudforum.org/forum/index.php?t=msg&th=123401&start=0&).

Can we get this fixed?
Re: Proposed fix to ckeditor.plugin [message #184894 is a reply to message #184891] Thu, 13 February 2014 16:10 Go to previous message
wferguss   Canada
Messages: 11
Registered: December 2013
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
After some further work, I'm not sure the blank line actually exists in the original file. I have a test and production instance. When I applied the ckeditor.plugin fix to the production instance, the download problem did not go away. I had to remove a blank line from a different plugin file (one I wrote myself). On the test instance this file did not have a blank line at the end.

In both cases the file needing to be fixed was the one listed last in cache/plugin_cache.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: How to use Search plugin hook
Next Topic: Bug & fix - undefined variable DBHOST in Undefined variable
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Dec 16 02:25:42 EST 2017

Total time taken to generate the page: 0.00653 seconds