FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Problem importing data before upgrading the forum (2.7.6->)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problem importing data before upgrading the forum (2.7.6->) [message #185391] Sun, 23 March 2014 11:13 Go to next message
mirek is currently offline  mirek
Messages: 2
Registered: March 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

I am running fudforum here:

ultimatepp.org/forum/

I would like to upgrade to recent version, but I have got stuck at first step:

Before doing on production machine, I wanted to test first on local one. I have installed 2.7.6 FUDForum there, got it working without troubles. Then I have dumped the forum data, imported and forum stopped to work. I am getting these errors in apache log:

[Sun Mar 23 16:45:30.911119 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Warning:  gettimeofday(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/FUDforum/include/core.inc on line 55
[Sun Mar 23 16:45:30.917598 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Trying to get property of non-object in /var/www/forum/index.php on line 965
[Sun Mar 23 16:45:30.917614 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Trying to get property of non-object in /var/www/forum/index.php on line 973
[Sun Mar 23 16:45:30.917616 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Trying to get property of non-object in /var/www/forum/index.php on line 976
[Sun Mar 23 16:45:30.917619 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Warning:  Creating default object from empty value in /var/www/forum/index.php on line 976
[Sun Mar 23 16:45:30.917626 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$time_zone in /var/www/forum/index.php on line 989
[Sun Mar 23 16:45:30.917629 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$locale in /var/www/forum/index.php on line 993
[Sun Mar 23 16:45:30.917643 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$id in /var/www/forum/index.php on line 1008
[Sun Mar 23 16:45:30.917645 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$id in /var/www/forum/index.php on line 1008
[Sun Mar 23 16:45:30.917650 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$ses_id in /var/www/forum/index.php on line 1020
[Sun Mar 23 16:45:30.917697 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$cat_collapse_status in /var/www/forum/theme/default/index.php on line 31
[Sun Mar 23 16:45:30.917702 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Notice:  Undefined property: stdClass::$sid in /var/www/forum/theme/default/index.php on line 38
[Sun Mar 23 16:45:30.917929 2014] [:error] [pid 4772] [client 127.0.0.1:53731] PHP Fatal error:  SQL Error has occurred, please contact the <a href="mailto:cxl@localhost?subject=SQL%20Error">administrator</a> of the forum and have them review the forum's SQL query log in /var/FUDforum/include/core.inc on line 188


and this is sql_error:

/var/www/forum/index.php:314<br />
/var/www/forum/theme/default/index.php:38<br />
/var/www/forum/index.php:1187<br />
) 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1<br />
Query: UPDATE fud26_ses SET sys_id='03a09d35b1f00cea4836f5e8f6d9eb06', forum_id=0, time_sec=1395589356, action='Browsing the &lt;a href=\&quot;index.php?t=index\&quot;&gt;forum list&lt;/a&gt;', returnto='' WHERE id=<br />
Server Version: 5.5.35-0ubuntu0.13.10.2<br />

?584       ?1395589369?(/var/www/forum/index.php:75<br />


It looks there is something wrong with sessions management, but as I am no PHP expert, I have hard time to figure that out.

Further note: As my suspection is that there might be something wrong with theming (which looks to get imported as well), I have recently tried to overwrite all files except messages and file attachements from "clean backup", but that does not helped either.

Any tips what might be wrong? BTW, I wonder whether the is an option to move just forum structure and messages?

Thanks,

Mirek
Re: Problem importing data before upgrading the forum (2.7.6->) [message #185420 is a reply to message #185391] Sun, 30 March 2014 08:48 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 2
Registered: March 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have spent some days over that and for the public entertainment and perhaps as hints of things that might be fixed, here is the list of issues I had to do to perform migration:

ultimatepp.org/forum/index.php?t=msg&th=8665&start=0&

Seriously, I would say that the whole forum dump process is inadequate, there appears to be way to much things that could go wrong. Perhaps it would be better to rather use some neutral text format for that, dumping SQL tables as they are is tricky...
Re: Problem importing data before upgrading the forum (2.7.6->) [message #185431 is a reply to message #185420] Mon, 31 March 2014 01:49 Go to previous message
naudefj is currently offline  naudefj   
Messages: 3681
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You are running an old unsupported release of FUDforum. If you neglect a forum this long, upgrading it is going to be painful (no matter what software you use).

As workaround to the dump & restore problem, try backing up the files and DB manually.
To restore, see "I've moved my forum to a new server, how do I get it to work again?" @ FAQ.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Installation failing (from SVN checkout)
Next Topic: What are correct file permissions for 3.04?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 20 07:22:26 EDT 2018

Total time taken to generate the page: 0.00650 seconds