FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » Working with a read only database
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Working with a read only database [message #186487] Mon, 25 August 2014 02:54
DaveQB is currently offline  DaveQB   
Messages: 109
Registered: January 2006
Location: Sydney
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Hi,

Is there any way to have a fudforum work with a read-only database?
I replicate to another server files and databases. It is a master-slave replication and so the slave is in read-only. It is to be used when the main server goes down as a temp server. Wordpress works, but it looks like FudForum does not. I am getting a:

Quote:
PHP Fatal error: SQL error has occurred! Please contact the <a href="mailto:user(at)example(dot)com?subject=SQL%20Error">administrator</a> and have them look at the Error Log Viewer in the forum's Admin Control Panel. in <fudforum>/include/core.inc on line 268


Looking in the file system at the "sql_error" file, we have this:

Quote:
1290: The MySQL server is running with the --read-only option so it cannot execute this statement<br />
Query: UPDATE ases SET sys_id=


I suspect it would be a session issue.

So can there be a way around this? Move sessions to the file system?
I just want it working enough that the forum can be read. If sessions where on the file system, then users might be able to login to read private area. I understand they would not be able to post etc.

Thanks.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Export to PDF
Next Topic: message storage file, foff and length question
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 13:50:38 EDT 2017

Total time taken to generate the page: 0.00582 seconds