FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Post count problems after migration (Migrated from UBBthreads to FUDforum but lost posts?)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Post count problems after migration [message #186695] Tue, 30 December 2014 17:46 Go to next message
Shanga_BP is currently offline  Shanga_BP   Romania
Messages: 6
Registered: December 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi folks,

I am facing a strange problem after I've migrated the forum from UBBthreads to FUD. I am looking in my admin panel and I am seeing this:

Forum Statistics:
Messages: 137494
Topics: 7610

Which is about right what I expected and should be.

But then on the public side of the forum, I see this:
Our users have posted a total of 78531 messages inside 4183 topics.

And a quick check on the top posters reveals they've lost about 50% of their posts counts. Which leaves me kinda baffled. Where are the missing posts hiding? Can anyone help with a suggestion? I've run consistency checks and optimize/repair on tables and everything I could get my hands on. With no results. I am kinda out of ideas...

Re: Post count problems after migration [message #186697 is a reply to message #186695] Wed, 31 December 2014 01:08 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3605
Registered: December 2004
Karma: 13
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The "missing" messages are probaly in the database, but not approved/published.
Re: Post count problems after migration [message #186698 is a reply to message #186697] Wed, 31 December 2014 06:58 Go to previous messageGo to next message
Shanga_BP is currently offline  Shanga_BP   Romania
Messages: 6
Registered: December 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Yep, they probably are. But (excuse my ignorance) is there a way to approve/publish them from admin? I have no clue why they got the status changed on importing, all the 137k messages should've been active.

EDIT: Actually looking at the _MSG table, it has all the 137k rows. So the messages are clearly inside the db. But what key exactly need I look for that prevents them from showing up? I might try and run an SQL query to mass-approve them if I knew what to look for. I've checked the APR key and it's "1" for all of them.

[Updated on: Wed, 31 December 2014 08:07]

Report message to a moderator

Re: Post count problems after migration [message #186699 is a reply to message #186698] Wed, 31 December 2014 08:31 Go to previous messageGo to next message
Shanga_BP is currently offline  Shanga_BP   Romania
Messages: 6
Registered: December 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
http://i.imgur.com/AaXviqh.jpg

I am looking here:
http://cvs.prohost.org/index.php?title=Fud30_msg

And all the keys seem ok to my untrained eye. Anyone knows what am I missing?
Re: Post count problems after migration [message #186701 is a reply to message #186699] Wed, 31 December 2014 10:32 Go to previous messageGo to next message
naudefj is currently offline  naudefj   
Messages: 3605
Registered: December 2004
Karma: 13
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Check for NULL or 0 values in fud30_msg.apr.
Run the consistency checker after any DB updates.
Re: Post count problems after migration [message #186702 is a reply to message #186701] Wed, 31 December 2014 18:54 Go to previous messageGo to next message
Shanga_BP is currently offline  Shanga_BP   Romania
Messages: 6
Registered: December 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Apr is set properly (i've run a mysql query and both 0 and NULL came out with zero results). It seems it's just the footer stats who are reporting strange numbers. I've also summed the individual user post counts (the new ones, after rebuilding them) and they do amount to 137k. So admin stats report the proper number, total user post counts sum up to 137k, that little box with stats keeps saying 70k... Maybe there's a different math behind it? It ignores certain forums?


And btw.. Happy New Year and thanks for creating an awesome piece of software (i am still getting the hang of it but I am starting to fall in love).

[Updated on: Wed, 31 December 2014 18:56]

Report message to a moderator

Re: Post count problems after migration [message #186703 is a reply to message #186702] Thu, 01 January 2015 13:54 Go to previous messageGo to next message
Shanga_BP is currently offline  Shanga_BP   Romania
Messages: 6
Registered: December 2014
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Oh my God...

After 4 days of hair pulling I finally solved the big mistery. It turns out the the footer statistics only take into account the index forums and completely ignore subforums. Why? Dunno. But I had a hunch when I saw unlogged users have different post count from logged users. And I moved a subforum up to index... and bingo 3k more posts showed up on the "Our users have posted a total of..." message.

Talk about a storm in a glass. Btw, although I do appreciate the dynamic factor of the footer count, I think not counting subforums is kinda annoying. Any idea where I can alter this function?

[Updated on: Thu, 01 January 2015 13:54]

Report message to a moderator

Re: Post count problems after migration [message #186704 is a reply to message #186703] Thu, 01 January 2015 14:20 Go to previous message
naudefj is currently offline  naudefj   
Messages: 3605
Registered: December 2004
Karma: 13
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Sounds like a bug to me.
Look at rebuild_stats_cache() .../src/logedin.inc.t
Remember to rebuild theme to deploy changes.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: fudforum and chrome cookie bug
Next Topic: Password protected forum & quick reply
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Feb 19 23:25:02 EST 2017

Total time taken to generate the page: 0.00489 seconds