FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » How To » Admin vs. users' post notifications (Why admin works but not member's post notification?)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Admin vs. users' post notifications [message #186770] Tue, 24 February 2015 06:45 Go to next message
Markku is currently offline  Markku   Romania
Messages: 8
Registered: February 2015
Location: Romania
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

My server does not allow email SMTP setup. The inbuilt 127.0.0.1 php.ini works fine to send notifications to the administrator's email address (myzzz(at)zzzdomain(dot)org). But does not work for forum users' post notifications e.g. when someone replies on their post.

What's the setup difference between admin and user notification? If there is a difference, can the two be merged to use the same script/setup?

[Updated on: Tue, 24 February 2015 06:46]

Report message to a moderator

Re: Admin vs. users' post notifications [message #186772 is a reply to message #186770] Tue, 24 February 2015 10:57 Go to previous messageGo to next message
GaryM is currently offline  GaryM   United States
Messages: 88
Registered: May 2013
Location: Seattle
Karma: 1
Member
add to buddy list
ignore all messages by this user
Do your users get private message notifications and have they also subscribed the forum that enables notification? There could be mail server issue, did you take a look for messages sitting in the mail queue or take look at the mail log?

The Global Settings Manager indicates email is sent using the standard PHP mail() function.



Re: Admin vs. users' post notifications [message #186773 is a reply to message #186772] Tue, 24 February 2015 12:15 Go to previous messageGo to next message
Markku is currently offline  Markku   
Messages: 8
Registered: February 2015
Location: Romania
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
The users' private messages work fine. Also the users have enabled the notification. No log errors appears. This what puzzles me and wondering if there is a script difference.

[Updated on: Tue, 24 February 2015 12:17]

Report message to a moderator

Re: Admin vs. users' post notifications [message #186778 is a reply to message #186773] Tue, 24 February 2015 19:29 Go to previous messageGo to next message
Markku is currently offline  Markku   
Messages: 8
Registered: February 2015
Location: Romania
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I did few tests by sending private messages to different users and all received the pm notification via email. Its the "Post Notification" which does not work when someone replies a user's post. Sounds like a bug.

Also I took a look in the database the difference between enabled or non-able notification. I was expecting to read in field "users_opt" yes or no but instead a sting of numbers. In my case (yes) 4357622 and (no) 4357620. Some users have the same numbers and others very different.
Re: Admin vs. users' post notifications [message #186779 is a reply to message #186778] Wed, 25 February 2015 03:49 Go to previous messageGo to next message
NeXuS is currently offline  NeXuS
Messages: 121
Registered: July 2010
Location: South Korea
Karma: 5
Senior Member
Contributing Core Developer
add to buddy list
ignore all messages by this user
Hi Markku, I'll look into it as soon as I can.

Anyway the user options are bitmasks, that's why you see a number: users with exactly the same options will have the same number, otherwise it will be different.
Re: Admin vs. users' post notifications [message #186780 is a reply to message #186779] Wed, 25 February 2015 06:30 Go to previous messageGo to next message
Markku is currently offline  Markku   
Messages: 8
Registered: February 2015
Location: Romania
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Thanks NeXus but I found that the error was mine. My modified theme was the cause.
Re: Admin vs. users' post notifications [message #186789 is a reply to message #186780] Sun, 01 March 2015 20:26 Go to previous message
NeXuS is currently offline  NeXuS   Korea, Republic of
Messages: 121
Registered: July 2010
Location: South Korea
Karma: 5
Senior Member
Contributing Core Developer
add to buddy list
ignore all messages by this user
Glad you found out the problem, but this is getting stupid. Changing a theme should not impact functionality such as email notifications. -.-
I'll do my best to release the new version ASAP.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Can you update from 2.8.1 to 3.05 directly
Next Topic: Lo-Fi Theme
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Dec 17 12:52:20 EST 2017

Total time taken to generate the page: 0.00848 seconds