FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » cgi.fix_pathinfo and nginx (Howto enable cgi.fix_pathinfo and get FUDForum working)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
cgi.fix_pathinfo and nginx [message #186915] Fri, 26 June 2015 01:59
DaveQB is currently offline  DaveQB   Australia
Messages: 109
Registered: January 2006
Location: Sydney
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Hi all,

If you're reading this, you may have ran into the same issue I did.

Symptoms
- FUDForum gives a 200 HTTP response but 0bytes of data (blank white page)
- No errors in your logs

I ran into this when Roundcube stopped working for me when I moved my webamail vhosts to a different server.

I found the issue here was that in my fpm php.ini config I had:

cgi.fix_pathinfo = 0


This was the default config for this server.
I changed this to:

cgi.fix_pathinfo = 1


And this got roundcube working. Yay! And it is safer too.

But now FUDForum was broken (see symptoms above)

Digging further, I pieced together that the solution was to add the below to your *.php block in nginx:

fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;


Once this is done you should now be getting 500 internal error codes from your server. The issue is it can't find the GLOBALS.php file due to the include path (well at least for me anyway)

So then set your include_path in your php pool config for the php pool your FUDForum website is using:

php_value[include_path]  = "/usr/share/php:/usr/share/pear:/var/local/FUDforum/scripts:/var/local/FUDforum/include:/var/local/FUDforum/include/theme/default"


Change the path to match the data folder of your installation (/var/local/FUDforum)
You should be right to go.

Ask any questions.

Ref: http://serverfault.com/questions/514157/how-to-set-php-include-path-for-php -fpm-in-nginx-config
http://fudforum.org/forum/index.php?t=msg&th=119217&goto=162124& ;#msg_162124
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: FATAL ERROR: could not open message store for forum id#60000 fudforum
Next Topic: Parse error: syntax error, unexpected T_NEW
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sun Jan 21 07:33:39 EST 2018

Total time taken to generate the page: 0.00642 seconds