FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » Template Editor fails when copying all template files (3.0.7)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Template Editor fails when copying all template files (3.0.7) [message #187163] Thu, 11 August 2016 08:43 Go to next message
Multitool is currently offline  Multitool   United Kingdom
Messages: 47
Registered: February 2012
Karma: 1
Member
add to buddy list
ignore all messages by this user
Template Editor fails when the copy "All template files" option is selected:

Warning: mkdir(): Permission denied in /var/forum/include/fs.inc on line 158 
Fatal error: Uncaught exception 'Exception' with message 'Cannot create directory "/var/forum/thm/test4//i18n/sr-ec".' in /var/forum/include/fs.inc:159 
Stack trace: #0 /var/www/html/forum/adm/admtemplates.php(55): fud_copy('/var/forum/thm/def...', '/var/forum/thm/tes...', '*', true) #1 {main} thrown in /var/forum/include/fs.inc on line 159 
Re: Template Editor fails when copying all template files (3.0.7) [message #187168 is a reply to message #187163] Fri, 12 August 2016 04:53 Go to previous messageGo to next message
naudefj is currently offline  naudefj   South Africa
Messages: 3624
Registered: December 2004
Karma: 17
Senior Member
Administrator
Core Developer
remove from buddy list
ignore all messages by this user
It may be a problem on your forum.
Please check file ownership & permissions for your installation.
Re: Template Editor fails when copying all template files (3.0.7) [message #187170 is a reply to message #187168] Fri, 12 August 2016 08:58 Go to previous messageGo to next message
Multitool is currently offline  Multitool   United Kingdom
Messages: 47
Registered: February 2012
Karma: 1
Member
add to buddy list
ignore all messages by this user
naudefj wrote on Fri, 12 August 2016 09:53
It may be a problem on your forum.
Please check file ownership & permissions for your installation.
The script fails to set execute permission on the tmpl, images and i18n directories when creating the new template directory structure, hence can't access them to populate them.
Permissions are set correctly on the base template directories from which the script should be copying.
I believe it's a bug.

Aw: Re: Template Editor fails when copying all template files (3.0.7) [message #187174 is a reply to message #187170] Sun, 14 August 2016 14:23 Go to previous messageGo to next message
alopezie is currently offline  alopezie   Germany
Messages: 90
Registered: September 2003
Karma: 1
Member
add to buddy list
ignore all messages by this user
it looks like you copy to a directory outside of your web root.
So most likely this directory does not have the "apache" rights (www-data.www-data usually), I guess the target directory is owned by root

Chown "/var/forum" to apache


Alopezie.de - das Forum zum Thema Haarausfall
Re: Aw: Re: Template Editor fails when copying all template files (3.0.7) [message #187186 is a reply to message #187174] Thu, 25 August 2016 06:05 Go to previous message
Multitool is currently offline  Multitool   United Kingdom
Messages: 47
Registered: February 2012
Karma: 1
Member
add to buddy list
ignore all messages by this user
The theme files are supposed to be outside the web root directory. The web directory is populated when the theme is rebuilt via the admin control panel.
The ownership and permissions are set correctly on all existing files and directories.
The options to copy "Header and Footer templates" and "Header Footer and CSS templates" work correctly - the script sets permissions correctly on the created directories.
Only the "All template files" option fails to set permissions correctly.

As I pointed out in my previous post, the ownership on the created directories is correct. The problem is that the directories for the new template are created without "execute" permission set.

It's a bug.

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Can not edit nor delete a Category & "SubCategory"
Next Topic: NNTP import won't work
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Oct 19 12:39:37 EDT 2017

Total time taken to generate the page: 0.00645 seconds