FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Bug Reports » NNTP import won't work
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
NNTP import won't work [message #187235] Thu, 02 February 2017 04:39 Go to next message
dchmelik is currently offline  dchmelik   United States
Messages: 9
Registered: August 2015
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm trying out adding some newsgroups to my FUDForum. I tested NNTP import with one, and it just said the following.

Job log: /var/FUDforum/scripts/nntp.php_8.log

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/extensions/snmp.so' - libnetsnmp.so.30: cannot open shared object file: No such file or directory in Unknown on line 0

Unable to establish connection to  on port 119 failed
With Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known

That snmp.so exists in that location on my server, so I don't know what went wrong.

[Updated on: Sun, 12 August 2018 03:11]

Report message to a moderator

Re: NNTP import won't work [message #187543 is a reply to message #187235] Sun, 12 August 2018 03:12 Go to previous messageGo to next message
dchmelik is currently offline  dchmelik   United States
Messages: 9
Registered: August 2015
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Since then (and two new FUDForum versions) it worked to import from NNTP manually. I can't test automating jobs yet because now I can't get into the category manager (new bug post about that.)

[Updated on: Sun, 12 August 2018 03:13]

Report message to a moderator

Re: NNTP import won't work [message #187545 is a reply to message #187543] Sun, 12 August 2018 04:33 Go to previous messageGo to next message
naudefj is currently offline  naudefj   United States
Messages: 3682
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
> Unable to establish connection to on port 119 failed
> With Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known

Looks like the remote NNTP server is rejecting your connection requests. This is hardly FUDforum's fault.
Re: NNTP import won't work [message #187547 is a reply to message #187545] Sun, 12 August 2018 23:18 Go to previous messageGo to next message
dchmelik is currently offline  dchmelik   United States
Messages: 9
Registered: August 2015
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Except the error message could've clarified.
It's working for most newsgroups now.

[Updated on: Sun, 12 August 2018 23:19]

Report message to a moderator

Re: NNTP import won't work [message #187571 is a reply to message #187547] Tue, 11 September 2018 00:26 Go to previous messageGo to next message
dchmelik is currently offline  dchmelik   United States
Messages: 9
Registered: August 2015
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
This is still the same topic, but specifically, NNTP import only works when I run it manually. I've set some import tasks to run at certain hours of the day. They just don't run at all, except manually.
Re: NNTP import won't work [message #187574 is a reply to message #187571] Thu, 13 September 2018 11:04 Go to previous message
naudefj is currently offline  naudefj   United States
Messages: 3682
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Use a scheduler like cron.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Datadump not backing up forum files
Next Topic: No Smilies!
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 23 14:52:26 EDT 2018

Total time taken to generate the page: 0.00850 seconds