FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Migrate and Upgrade ISsue (Migrate, restore, and upgrade messes up redirects)
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Migrate and Upgrade ISsue [message #187630] Mon, 03 December 2018 03:23 Go to next message
manpreetn is currently offline  manpreetn   India
Messages: 4
Registered: November 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I am running fudforums 3.0.4 and have to migrate them to a new host and upgrade to 3.0.9.

Steps taken
1. Install 3.0.4 on the new host at /var/www/
2. Check if the default install is working. (which works)
2. Take backup from current hosting and restore to the new location. from /var/www/virtuals/
3. Run consistency check
4. Run reindex

At this point no matter what link I click it redirects to the same page.1
1. Login works I can go into administration using user/password from the newly restored DB
2. All links on first page except Administration(after loing) return to same page.

Server Setup :
1. Debian Stretch
2. Apache 2.0
3. php5.6 (since 7.0 is missing a function)
4. mysql (hosted locally)

my .htaccess
<pre>
php_value output_buffering 64000
php_value variables_order GPCS
php_flag implicit_flush 0
php_flag register_globals 0
php_flag register_argc_argv 0
php_flag magic_quotes_gpc 0
php_flag session.use_trans_sid 0
php_flag expose_php 0

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php/$1 [L]

<Limit CONNECT>
order deny,allow
deny from all
</Limit>


## EXPIRES CACHING ##

ExpiresActive On
ExpiresByType image/jpg "access plus 1 year"
ExpiresByType image/jpeg "access plus 1 year"
ExpiresByType image/gif "access plus 1 year"
ExpiresByType image/png "access plus 1 year"
ExpiresByType text/css "access plus 1 month"
ExpiresByType application/pdf "access plus 1 month"
ExpiresByType text/x-javascript "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 year"
ExpiresDefault "access plus 2 days"

## EXPIRES CACHING ##

</pre>


Apache config

<VirtualHost *:80>
ServerAdmin webmaster(at)example(dot)com
DocumentRoot /var/www/forums.example.com/
ServerName forums.example.com
ErrorLog /var/log/apache2/forums.example.com/error_log
CustomLog /var/log/apache2/forums.example.com/access_log combined
<Directory /var/www/forums.example.com/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>
</VirtualHost>
Re: Migrate and Upgrade ISsue [message #187631 is a reply to message #187630] Mon, 03 December 2018 13:57 Go to previous messageGo to next message
naudefj is currently offline  naudefj   United States
Messages: 3687
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It might be a problem with your rewrite rules?
Take them out to see if it helps.

[Updated on: Tue, 04 December 2018 13:39]

Report message to a moderator

Re: Migrate and Upgrade ISsue [message #187632 is a reply to message #187631] Tue, 04 December 2018 01:00 Go to previous messageGo to next message
manpreetn is currently offline  manpreetn   
Messages: 4
Registered: November 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
If I remove the rewrite rules I get 404 on all links.
Re: Migrate and Upgrade ISsue [message #187633 is a reply to message #187632] Tue, 04 December 2018 01:02 Go to previous messageGo to next message
manpreetn is currently offline  manpreetn   
Messages: 4
Registered: November 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have been hunting the forums for days to find if there was an example or suggested apache config but couldnt find any.
Re: Migrate and Upgrade ISsue [message #187637 is a reply to message #187633] Tue, 04 December 2018 13:43 Go to previous messageGo to next message
naudefj is currently offline  naudefj   United States
Messages: 3687
Registered: December 2004
Karma: 19
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
My .htaccess contains the following lines, nothing more:

RewriteEngine On
RewriteBase /forum
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php/$1 [L]
Re: Migrate and Upgrade ISsue [message #187638 is a reply to message #187637] Wed, 05 December 2018 02:57 Go to previous message
manpreetn is currently offline  manpreetn   
Messages: 4
Registered: November 2018
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I think the rewrite rules depend on the way the system is configured since i am missing that info
1. forum web : /var/www/forums.example.com
2. forum data: /var/www/FUDforum

I changed my .htaccess to
RewriteEngine On
RewriteBAse /forum
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php/$1 [L]
with no effect actually it started givingInternal Server error
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Failing to change forum to RTL
Next Topic: FUDforum2Go Appliance for Windows
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 10 11:11:16 EST 2018

Total time taken to generate the page: 0.00799 seconds