FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » Database discussions » error message on upgrade
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
error message on upgrade [message #10242] Sun, 25 May 2003 17:15 Go to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

I got this message after running the latest upgrade script

<Fetch SQL archive
SQL archive is now avaliable
Beginning SQL Upgrades
MySQL Error: #1062 (Duplicate entry '8-200' for key 2): ALTER TABLE fud_forum_read ADD UNIQUE(forum_id,user_id)>

I would be greatful for any help.


Got Torque?
Re: error message on upgrade [message #10249 is a reply to message #10242] Mon, 26 May 2003 10:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to run the following query:

DELETE FROM fud_forum_read WHERE forum_id=8 AND user_id=200 LIMIT 1;


FUDforum Core Developer
Re: error message on upgrade [message #10258 is a reply to message #10249] Mon, 26 May 2003 11:33 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

please see your PM

Got Torque?
Re: error message on upgrade [message #10317 is a reply to message #10258] Tue, 27 May 2003 18:51 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

I ran the latest upgrade and get this Warning during the upgrade

Warning: getimagesize(/usr/home/web/users/a0003196/html/fforum/www/images/custom_avatars/30) [function.getimagesize]: failed to create stream: No such file or directory in /usr/home/web/users/a0003196/html/fforum/www/upgrade.php on line 1138

after the upgrade completed, went to log on and got this:

(index.php) 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
Query: SELECT u.id, u.alias, u.is_mod, u.custom_color FROM fud_ses s INNER JOIN fud_users u ON u.id=s.user_id WHERE s.time_sec>1054075504 AND u.invisible_mode='N' ORDER BY s.time_sec DESC LIMIT
Server Version: 4.0.12-log



Thanks for the great support.


Got Torque?

[Updated on: Tue, 27 May 2003 18:53]

Report message to a moderator

Re: error message on upgrade [message #10323 is a reply to message #10317] Wed, 28 May 2003 08:40 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Somehow your GLOBALS.php is missing the $MAX_LOGGEDIN_USERS variable.

To solve the problem to the following:

1) Go to the admin control panel directorly (your_forum_url/adm/)
2) On the settings panel find settings called 'Maximum number of logged in users to show' and set it's value to a number (suggested 25).


FUDforum Core Developer
Re: error message on upgrade [message #10330 is a reply to message #10323] Wed, 28 May 2003 09:30 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

that value was/is 25.

Got Torque?
Re: error message on upgrade [message #10331 is a reply to message #10330] Wed, 28 May 2003 09:32 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Make sure that your GLOBALS.php are not compiles of each other but rather symlinks to the 'real' GLOBALS.php inside the include directory.

FUDforum Core Developer
Re: error message on upgrade [message #10332 is a reply to message #10331] Wed, 28 May 2003 09:37 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

I've read about this in some of your other posts but don't know how to check this.

Got Torque?
Re: error message on upgrade [message #10333 is a reply to message #10332] Wed, 28 May 2003 09:39 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Download the files and see if they are identical, if they are not, you are not using symlinks.

FUDforum Core Developer
Re: error message on upgrade [message #10335 is a reply to message #10333] Wed, 28 May 2003 09:58 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

checked the 'real' globals.php vs one in my www dir. It is not identical to the 'real' globals.php

example:
'real' $PRIVATE_TAGS = "NONE"; /* toggle N:ML:HTML */



'www_dir' $PRIVATE_TAGS = "ML"; /* toggle N:ML:HTML */


will keep checking.



Got Torque?
Re: error message on upgrade [message #10336 is a reply to message #10335] Wed, 28 May 2003 10:10 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Victor_M and I use the same hosting service. We both started to have problems when they "upgraded". I'm thinking my symlinks should look like:

<?php
include_once "/path/to/include/GLOBALS.php";
?>

Per your advice to Victor_M pasted below

Re: Question about GLOBALS.php
Mon, 26 May 2003 07:41

Normally on *nix systems there is 1 GLOBALS.php inside the incldue/ directory and 2 symlinks to this file. One of those symlinks
is inside the forum's web root directory and the other inside the adm/ directory.

On Win32, since symlinks are not supported there are 3 GLOBALS.php, the ones that are symlinks on *nix are basically
<?php
include_once "/path/to/include/GLOBALS.php";
?>


what do you think??


Got Torque?
Re: error message on upgrade [message #10338 is a reply to message #10336] Wed, 28 May 2003 10:23 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
<?php
include_once "/path/to/include/GLOBALS.php";
?>


Will work, but I am not sure if that'll work once you start changing settings via the settings control panel. Since this solution was only intended for win32 systems.


FUDforum Core Developer
Re: error message on upgrade [message #10339 is a reply to message #10338] Wed, 28 May 2003 10:41 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Ahh

my hosting info:

Web Server: Apache/2.0.45 (Unix) FrontPage/5.0.2.2626

so would this apply to me?

Normally on *nix systems there is 1 GLOBALS.php inside the incldue/ directory and 2 symlinks to this file. One of those symlinks is inside the forum's web root directory and the other inside the adm/ directory.

How do I create these symlinks to my 'real' globals.php? Just put copies where they should be?? It can't be that easy.

sorry for all the questions, thanks for all the help.


Got Torque?
Re: error message on upgrade [message #10340 is a reply to message #10339] Wed, 28 May 2003 11:12 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You are not using Win32 that much is clear.

Run the following script:
<?php
$real_path
= "/path/to/include/GLOBALS.php"
include($real_path);

@
unlink($WWW_ROOT_DISK . 'GLOBALS.php');
@
unlink($WWW_ROOT_DISK . 'adm/GLOBALS.php');

symlink($real_path, $WWW_ROOT_DISK . 'GLOBALS.php');
symlink($real_path, $WWW_ROOT_DISK . 'adm/GLOBALS.php');
?>


FUDforum Core Developer
Re: error message on upgrade [message #10341 is a reply to message #10340] Wed, 28 May 2003 11:35 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

installed into my www_server_root dir.
chmod to 666.
ran the script.

get

Internal Server Error


Got Torque?
Re: error message on upgrade [message #10342 is a reply to message #10341] Wed, 28 May 2003 12:10 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
hmmm can you access the admin control panel?

FUDforum Core Developer
Re: error message on upgrade [message #10343 is a reply to message #10342] Wed, 28 May 2003 12:32 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Yes, I used the admin cp file manager to install the last script.

Got Torque?
Re: error message on upgrade [message #10346 is a reply to message #10343] Wed, 28 May 2003 12:49 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
So the error you are seeing only appears when you try to access the forum's from page?

Try rebuilding the theme and see if the problem goes away, if it does not make the 'default' theme the default theme (if you had not done so already).


FUDforum Core Developer
Re: error message on upgrade [message #10347 is a reply to message #10346] Wed, 28 May 2003 12:54 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Quote:

So the error you are seeing only appears when you try to access the forum's from page?


correct.

On the Theme Mgmt Page I see this warning...

Warning: file_get_contents(/usr/home/web/users/a0003196/html/fforum/data/thm/default/i18n/_vti_cnf/locale) [function.file-get-contents]: failed to create stream: No such file or directory in /usr/home/web/users/a0003196/html/fforum/www/adm/admthemes.php on line 239

is/was set to default


Go ahead with the rebuild??


Got Torque?
Re: error message on upgrade [message #10348 is a reply to message #10347] Wed, 28 May 2003 12:58 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
yes

FUDforum Core Developer
Re: error message on upgrade [message #10349 is a reply to message #10348] Wed, 28 May 2003 13:04 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Ok I did this is what popped up

Warning: copy(/usr/home/web/users/a0003196/html/fforum/datasql/mysql/db.inc) [function.copy]: failed to create stream: No such file or directory in /usr/home/web/users/a0003196/html/fforum/data/include/compiler.inc on line 439
unable to make directory (/usr/home/web/users/a0003196/html/fforum/datainclude/theme)


hmmmm looks like I am missing a "/"
(....datainclude/theme)...)


Got Torque?
Re: error message on upgrade [message #10350 is a reply to message #10349] Wed, 28 May 2003 13:08 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Looks like it, edit your GLOBALS.php and make sure ALL paths have / in the end.

FUDforum Core Developer
Re: error message on upgrade [message #10351 is a reply to message #10349] Wed, 28 May 2003 13:31 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Info:

I noticed on the global config panel, my DATA ROOT dir info was not there, added in (this was earlier), went back just now and it WAS missing a / at the end.

Downloaded and checked the GLOBALS.php, all paths have the "/" at the end.

Went to Theme Mgmt, ran "rebuild" get this:

Warning: file_get_contents(/usr/home/web/users/a0003196/html/fforum/data//thm/default/i18n/_vti_cnf/locale) [function.file-get-contents]: failed to create stream: No such file or directory in /usr/home/web/users/a0003196/html/fforum/www/adm/admthemes.php on line 239






Got Torque?
Re: error message on upgrade [message #10354 is a reply to message #10351] Wed, 28 May 2003 14:12 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
That's fine... does the forum work now?

FUDforum Core Developer
Re: error message on upgrade [message #10355 is a reply to message #10354] Wed, 28 May 2003 14:14 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

no, I can get into the admin cp but not the main page

http://scoutswest.com/fforum/www/index.php


Got Torque?
Re: error message on upgrade [message #10356 is a reply to message #10355] Wed, 28 May 2003 14:17 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I see a message about an sql error, go to the error log viewer and see what the error is.

FUDforum Core Developer
Re: error message on upgrade [message #10357 is a reply to message #10356] Wed, 28 May 2003 14:20 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

this is the last error in the error log


Wed May 28 18:22:32 GMT 2003 (index.php) 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
Query: SELECT u.id, u.alias, u.is_mod, u.custom_color FROM fud_ses s INNER JOIN fud_users u ON u.id=s.user_id WHERE s.time_sec>1054145852 AND u.invisible_mode='N' ORDER BY s.time_sec DESC LIMIT
Server Version: 4.0.12-log
[Referring Page] http://fud.prohost.org/forum/index.php?t=selmsg&unread=1&rid=876&frm_id=


Got Torque?
Re: error message on upgrade [message #10358 is a reply to message #10357] Wed, 28 May 2003 14:27 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Ok, you need to make sure that the GLOBALS.php that is being included has the variable I mentioned in my prior messages.

FUDforum Core Developer
Re: error message on upgrade [message #10360 is a reply to message #10358] Wed, 28 May 2003 14:51 Go to previous messageGo to next message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

You must mean the $MAX_LOGGEDIN_USERS variable.

I do not see that variable in my www_server_root GLOBALS.php but do see it in my include GLOBALS.php

soooo are you saying to ad "$MAX_LOGGEDIN_USERS" to the GLOBALS.php file in my www_server_root?

or delete all the GLOBALS.php files (except the on in include) then rebuild the theme? create syslinks to the include_GLOBALS.php file. (not that I know how to do that)


chmod (www_server_root) GLOBALS.php and index are 644, if that helps.

sorry to be such a pain.


Got Torque?

[Updated on: Wed, 28 May 2003 16:08]

Report message to a moderator

Re: error message on upgrade FIXED!! [message #10373 is a reply to message #10360] Thu, 29 May 2003 10:08 Go to previous message
scoutzilla is currently offline  scoutzilla   United States
Messages: 163
Registered: April 2002
Location: Southern Califorina
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user

Looks like the upgrade took. Sometimes I guess it takes a little time for my hosting service servers to accept and post the changes. Now if I can get my default icons back I will be soooooo happy..

Got Torque?

[Updated on: Thu, 29 May 2003 12:56]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: How to load my SQL data into the left frame of phpMyAdmin ..
Next Topic: Change of Usergroup
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Dec 14 08:23:30 EST 2017

Total time taken to generate the page: 0.01080 seconds