FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » FUDForum 2.0 Alpha 1.9.6 Release
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
FUDForum 2.0 Alpha 1.9.6 Release [message #1401] Thu, 11 April 2002 19:46 Go to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This is a MAJOR bug fixing release it contains numerous code and layout fixes.

FUDforum Core Developer

[Updated on: Tue, 16 April 2002 11:50]

Report message to a moderator

Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1404 is a reply to message #1401] Fri, 12 April 2002 07:33 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I tried to use/install the forum, and I found some problem:

1) When I try to register, a MySQL error is raised;

Quote:


Query Failed: INSERT INTO fud2_users ( login, passwd, name, email, display_email, notify, notify_method, ignore_admin, private_messages, gender, icq, aim, yahoo, msnm, append_sig, posts_ppg, time_zone, bday, invisible_mode, last_visit, conf_key, user_image, join_date, location, avatar, style, coppa, occupation, interests, referer_id, show_sigs, last_read, avatar_loc, avatar_approved, sig, default_view ) VALUES ( 'ctbk', 'da343414945bc15ed10e1a6968945cb4', 'Stefano', 'xxx(at)xxxxxx(dot)it', 'Y', 'Y', 'EMAIL', 'N', 'Y', '', NULL, NULL, NULL, NULL, 'Y', '0', 'Europe/Rome', 0000, 'N', 1018608521, '4ada45fecdb3239a8768db12bad07d68', NULL, 1018608521, '', 0, , 'N', NULL, NULL, 1, 'Y', 1018608521, NULL, 'NO', NULL, 'msg' )
Reason: You have an error in your SQL syntax near ' 'N', NULL, NULL, 1, 'Y', 1018608521, NULL, 'NO'' at line 66
From: /var/www/fud/register.php
Server Version: 3.23.42




2) If I create a Moderated Forum, Mod Queue doesn't work at all;


3) some directory isn't created in the install process (DATADIR/messages; DATADIR/settings).

4) the install process and template recompiling took *a lot*, like 5-8 minutes to finish. My HW is a Linux PIII800 with 512MB RAM, and there's nothing else running on it. But maybe this is a prob of my config.


Anyway, from what I can see this forum is gonna rock! Smile I'm seriously thinking to migrate our site forum (~40.000 forum pageviews/day, from 1.500 to 3.500 messages/day) from XMB to this one... do you have any idea when 2.0 version will be usable?

P.S.: Permission/Grouping management is great!


~
~
:wq

[Updated on: Fri, 12 April 2002 08:49]

Report message to a moderator

Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1406 is a reply to message #1404] Fri, 12 April 2002 10:31 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Registration bug has been fixed and a new release will be avaliable shortly.

As for compiling speed, I dunno it could be that your php is not as highly optimized as ours Razz

On a dual Celeron 433 the entire forum compiles in ~3.67 minutes and on a production server Dual P3 733 it takes ~1.67 minutes.
On my home computer celeron 1.1ghz it takes 1.9i7 minutes.

Please note that the compilation is SINGLE threaded process so the benefit of a single cpu shouldn't make more then 5% difference.

Could you tell me which PHP version you are running?


FUDforum Core Developer
Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1409 is a reply to message #1406] Fri, 12 April 2002 11:22 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
My PHP Version is 4.0.99

Anyway it's not a big issue, once compiled the pages are quite fast indeed, I was just curious about the reason 4 this slowness

Later,
Ste


~
~
:wq
Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1410 is a reply to message #1409] Fri, 12 April 2002 11:28 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
ctbk wrote on Fri, 12 April 2002 11:22 AM

My PHP Version is 4.0.99

Anyway it's not a big issue, once compiled the pages are quite fast indeed, I was just curious about the reason 4 this slowness

Later,
Ste


I think you mean 4.0.9?

Well the compiler is "fast enough" at the moment, once we are passed the feature addition stage it is likely it'll be optimized.

Even at 5-8 minute complete compile should be okie, since you'd only do a complete compile if you are install/upgrading or changing the forum's language.

In most cases you'd be editing 2-3 pages which will compile in few seconds.


FUDforum Core Developer
Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1411 is a reply to message #1404] Fri, 12 April 2002 11:36 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Quote:


2) If I create a Moderated Forum, Mod Queue doesn't work at all;



I've tried using this feature on our development forum and it appears to work A OK.

Here is the process that I went through (logged in as admin):

1) Made a forum moderated
2) Went into forum & posted new thread
3) Now I see Moderation Queue of 1 message
4) Goto control panel approve message
5) Return back to thread view of the moderated forum and I can see the thread I've created.


FUDforum Core Developer
Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1414 is a reply to message #1411] Sat, 13 April 2002 05:18 Go to previous messageGo to next message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I'm about to download the new alpha version and I will tell you if the problem persists, anyway I had problems creating a new topic with a poll in it in a moderated forum... I hope to be able to give a better report soon.

Later,
Ste


~
~
:wq
Re: FUDForum 2.0 Alpha 1.9.6 Release [message #1492 is a reply to message #1414] Wed, 17 April 2002 05:29 Go to previous message
ctbk is currently offline  ctbk   Italy
Messages: 142
Registered: April 2002
Location: Milan, Italy
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I downloaded latest alpha version and couldn't reproduce the bug anymore Smile

Later,
Ste


~
~
:wq
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Lots of Feature Requests
Next Topic: Translations of buttons
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 07:38:54 EDT 2017

Total time taken to generate the page: 0.00814 seconds