FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » FUDforum 3.0+ » Problem with installer
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problem with installer [message #2058] Sun, 28 April 2002 17:35 Go to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hello,
Due to the changes I'm about to install the forum from the scratch. But there's an error striking me. Ive had this already this morning just when going to step 2 the script spits out the following error:
Quote:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 2411058 bytes) in /usr/local/httpd/htdocs/kunden/web180/html/install.php on line 218
Server configuration is nothing to worry about: Apache 1.3.19, PHP 4.06 (safe mode is off, register globals on), MySQL 3.23.37. Haven't had this yesterday or the day before and the server's settings haven't changed either. Right now it seems that the error message won't disappear anymore Sad Any help would be gladly appreciated
bye Ken
Re: Problem with installer [message #2059 is a reply to message #2058] Sun, 28 April 2002 18:01 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Hmmm...

Well the "entire" install script is 2 megs, somehow PHP made it use over 8 megs of memory.... 99% of which is actually a base64 string.

Tells you something about the design of PHP, or more precicely lack there of.

I've added a code to install script to try to set the memory limit to 20 megs.

Also, php 4.06 has a bug with memory limit, if you want to use memory limit you MUST patch your php. Here is the url to the patch:
http://www.php.net/do_download.php?download_file=php-4.0.6-memlimit.diff.gz

Patch Notes:
# (This patch fixes a bug in the 4.0.6 memory limit option. This is only needed when configuring PHP with --enable-memory-limit). If you have problems applying the patch try using GNU patch.


FUDforum Core Developer
Re: Problem with installer [message #2060 is a reply to message #2059] Sun, 28 April 2002 18:20 Go to previous messageGo to next message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Yes I ve heard about that bug and now it seems to be the first time I'm actually victim of it. Unfortunately I'm not root of that server, just have an account there, because else there would run apache 2.0.35 MySQL 3.23.49 and php 4.2.0 instead Smile. Hm since the hoster obviously didn't bother to apply the patch, is there a workaround that I can install the forum?
Re: Problem with installer [message #2061 is a reply to message #2060] Sun, 28 April 2002 18:27 Go to previous message
Olliver   Germany
Messages: 443
Registered: March 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I dunno why this happened but somehow the server suddenly has decided to continue now Very Happy Ok expect an updated German message file once I completed installation.
bye Ken
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: How to approve s.o with COPPA enabled?
Next Topic: Uploading avatar in profile quits with fatal error
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Oct 23 15:02:29 EDT 2017

Total time taken to generate the page: 0.00660 seconds