FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Undefined template: "TEMPLATE" inside "registered_on_date"
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Undefined template: "TEMPLATE" inside "registered_on_date" [message #21131] Mon, 15 November 2004 18:14 Go to next message
Joseph is currently offline  Joseph   United States
Messages: 5
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
After the very last click I get a blank page with this error on it:
Undefined template: "TEMPLATE" inside "registered_on_date"

I cannot find a reason for it. I previously got the error "dmsg_custom_tags" inside "drawpmsg.inc.t" but found an answer to that by downloading a replacing the compiler.inc file at the language selection screen.

server root and server data root are both owned by 'nobody' with full (-rwxrwxrwx) permissions (just to make sure thats not a problem).

Any advice would be greatly appreciated!

J.

Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21132 is a reply to message #21131] Mon, 15 November 2004 18:15 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
What version are you installing?


FUDforum Core Developer
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21133 is a reply to message #21132] Mon, 15 November 2004 18:19 Go to previous messageGo to next message
Joseph is currently offline  Joseph   United States
Messages: 5
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
i guess that would help.. I'm attempting to install 2.6.8
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21135 is a reply to message #21131] Mon, 15 November 2004 18:46 Go to previous messageGo to next message
Joseph is currently offline  Joseph   United States
Messages: 5
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
more info just in case:

fedora core 3
apache 2.0.52
php 5.0.2 (--with-apxs2 and --with-mysql)
mysql 4.1.7-max


hope this helps

J
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21136 is a reply to message #21135] Mon, 15 November 2004 19:14 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can't replicate on PHP 4 on my test server. Can you try using PHP 4.3.9?

FUDforum Core Developer
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21161 is a reply to message #21136] Wed, 17 November 2004 10:35 Go to previous messageGo to next message
Joseph is currently offline  Joseph   United States
Messages: 5
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
didn't seem to make any sort of difference. i removed php5.0.2 all together and compiled php4.3.9 with mysql and apxs. verified libphp4.so is the only php module in /modules and removed libphp5 from httpd.conf.

reran the install.php and it goes perfectly right to the end. initially i got: Undefined template: "dmsg_custom_tags" inside "drawpmsg.inc.t" so, as before, i replaced the compiler.inc at the language selection screen and continued but still got: Undefined template: "TEMPLATE" inside "registered_on_date".

does php need to be specifically configured to use anything other than apxs and mysql? could the MAX version of the mysql server im running cause problems?

As a test, i am also going to download and attempt to install 2.6.7 just to see what happens.

I appreciate your help Smile
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21162 is a reply to message #21161] Wed, 17 November 2004 10:46 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Are you installing over previous install attempts or in a new directory each time?

FUDforum Core Developer
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21163 is a reply to message #21162] Wed, 17 November 2004 12:43 Go to previous messageGo to next message
Joseph is currently offline  Joseph   United States
Messages: 5
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
completely new directory and the dir that php5 was in has been deleted. i wrote a quick index.php that displays phpinfo(); in the browser which shows 4.3.9 and a php --version from the command line shows 4.3.9 as well.

also.. when i tried to install FUDforum2.6.7 i recreated the database in mysql which i call simply 'forum' and granted all priviliges to the forum user to the database and get the following error:

Failed to create table "fud_action_log" ("CREATE TABLE fud26_action_log ( id INT NOT NULL AUTO_INCREMENT PRIMARY KEY, logtime BIGINT NOT NULL DEFAULT 0, logaction VARCHAR(100), user_id INT NOT NULL DEFAULT 0, a_res VARCHAR(100), a_res_id INT NOT NULL DEFAULT 0 DEFAULT CHARACTER SET utf8 COLLATE utf8 )"), SQL Reason: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'CHARACTER SET utf8 COLLATE utf8 )' at line 1

so i went into install.php and commented out the line that sent that command to the mysql server and it completed the installation without any other problems but i thought i would mention it just in case it could case other problems while actually using the forum.

Just logged in as admin and its incredible. Very nice. I am going to try running just the upgrade script to 2.6.8 and see how that works.
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #21164 is a reply to message #21163] Wed, 17 November 2004 13:23 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The bug you mentioned was fixed in 268.

I am quite confused by why 268 refused to be installed, I tried but no matter what I do I cannot replicate the bug.


FUDforum Core Developer
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #22324 is a reply to message #21164] Thu, 27 January 2005 14:20 Go to previous messageGo to next message
bostrick is currently offline  bostrick   United States
Messages: 2
Registered: January 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm getting the same bug... I've tried replacing
"TEMPLATE" refs in /var/www/FUDforum/thm/default/i18n/english/msg
with simple text, and can get by one problematic TEMPLATE only to get bit by the next one.

seems to be related to date related TEMPLATEs, whatever they are...

[root@... english]# cat /etc/redhat-release
Fedora Core release 2 (Tettnang)
[root@... english]# rpm -q php
php-4.3.10-2.4

[Updated on: Thu, 27 January 2005 14:21]

Report message to a moderator

Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #22325 is a reply to message #22324] Thu, 27 January 2005 16:41 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Are you using a custom template set?
What are the exact errors reported by the forum?


FUDforum Core Developer
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #22335 is a reply to message #22325] Fri, 28 January 2005 11:41 Go to previous messageGo to next message
bostrick is currently offline  bostrick   United States
Messages: 2
Registered: January 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
had accidently downloaded 2.6-8. Upgrading to 2.6-9, installation went flawlessly. thanx! --bowe
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #164858 is a reply to message #22335] Sun, 20 March 2011 03:26 Go to previous messageGo to next message
simonlnu is currently offline  simonlnu   Canada
Messages: 19
Registered: March 2011
Location: Tiohtiake
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I'm getting this when I added some localisation files, for the post and topic icons (tree view, new topic, etc) so I could colorise them to match the colours in the CSS. Obviously I did something wrong... any hints/docs I should check out/read ?
Re: Undefined template: "TEMPLATE" inside "registered_on_date" [message #164859 is a reply to message #164858] Sun, 20 March 2011 03:29 Go to previous message
simonlnu is currently offline  simonlnu   Canada
Messages: 19
Registered: March 2011
Location: Tiohtiake
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
OK, just read the wiki page here: http://cvs.prohost.org/index.php/Button - this will work around this problem. thanks

Update: one better than that - for future reference, for other people - I left out the locale stuff, and kept the localised images, so I just have:

i18n/en/   
  img


and:

i18n/en/img:
  flat_view.gif
  homepage.gif
  msg_about.gif
  msg_delete.gif
  msg_edit.gif
  msg_email.gif
  msg_forward.gif
  msg_pm.gif
  msg_quote.gif
  msg_reply.gif
  new_pm.gif
  new_thread.gif
  post_reply.gif
  show_posts.gif
  tree_view.gif

[Updated on: Sun, 20 March 2011 04:33]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Consistency fail after update from 3.0.0 to 3.0.2
Next Topic: update 2.7.7 > 3.0
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Jul 18 18:30:04 EDT 2018

Total time taken to generate the page: 0.00832 seconds