FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » FUDforum in eGroupWare » several errors in fudforum
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
several errors in fudforum [message #21446] Tue, 30 November 2004 10:53 Go to next message
eisy is currently offline  eisy   Germany
Messages: 6
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi *,

some days ago, I installed egroupware 1.0.0.006 on a Linux box.
I followd the instructions and everything works fine so far.
The only thing which behaves strange is fudforum:

When I try to post a new topic in TestForum, I get this error:

Parse error: parse error, unexpected T_STRING in /var/www/localhost/htdocs/egroupware/fudforum/3814588639/theme/default/post .php on line 2018
--
When I try to send a private message to a user, I get this error:

Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING in /var/www/localhost/htdocs/egroupware/fudforum/3814588639/theme/default/ppos t.php on line 980
--
When I try to open my profile, I get something like this thing, which I have attached.

Does somebody have any hints for me?

Thanks,
Sven
  • Attachment: index.php
    (Size: 62.77KB, Downloaded 534 times)
Re: several errors in fudforum [message #21448 is a reply to message #21446] Tue, 30 November 2004 11:04 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
could you attach the two files mentioned in the error and I'll take a look @ why those errors are happening.

FUDforum Core Developer
Re: several errors in fudforum [message #21449 is a reply to message #21446] Tue, 30 November 2004 11:19 Go to previous messageGo to next message
eisy is currently offline  eisy   Germany
Messages: 6
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Here is No. 1
  • Attachment: post.zip
    (Size: 38.98KB, Downloaded 533 times)
icon14.gif  Re: several errors in fudforum [message #21450 is a reply to message #21448] Tue, 30 November 2004 11:21 Go to previous messageGo to next message
eisy is currently offline  eisy   Germany
Messages: 6
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
... and here comes No. 2.

Thank you for your quick reply!!
  • Attachment: ppost.zip
    (Size: 20.75KB, Downloaded 494 times)
Re: several errors in fudforum [message #21461 is a reply to message #21450] Tue, 30 November 2004 15:51 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The cause for the error is the same in both cases...

What version of PHP are you using?


FUDforum Core Developer
Re: several errors in fudforum [message #21464 is a reply to message #21461] Wed, 01 December 2004 03:08 Go to previous messageGo to next message
eisy is currently offline  eisy   Germany
Messages: 6
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Here is my phpinfo:

PHP Version 4.3.9

System Linux ns1 2.6.9-gentoo-r6 #1 Thu Nov 25 11:12:32 CET 2004 i686
Build Date Nov 27 2004 11:16:32
Configure Command './configure' '--prefix=/usr' '--host=i686-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--with-apxs2=/usr/sbin/apxs2' '--with-ndbm=/usr' '--with-db4=/usr' '--with-mcrypt=/usr' '--with-mhash=/usr' '--without-interbase' '--without-ming' '--without-swf' '--without-sybase' '--with-gdbm=/usr' '--without-fdftk' '--without-java' '--without-mcal' '--without-unixODBC' '--without-pgsql' '--without-snmp' '--with-xpm-dir=/usr/X11R6' '--without-gmp' '--without-mssql' '--with-pdflib=/usr' '--with-gd' '--enable-gd-native-ttf' '--with-png=/usr' '--with-png-dir=/usr' '--with-jpeg=/usr' '--with-jpeg-dir=/usr' '--enable-exif' '--with-tiff=/usr' '--with-tiff-dir=/usr' '--with-mysql=/usr' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-freetype-dir=/usr' '--with-ttf=/usr' '--with-t1lib=/usr' '--with-gettext' '--with-qtdom=/usr/qt/3' '--with-pspell=/usr' '--with-openssl=/usr' '--with-imap=/usr' '--with-ldap=/usr' '--with-dom=/usr' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--without-kerberos' '--with-pam' '--disable-memory-limit' '--disable-ipv6' '--without-yaz' '--disable-debug' '--without-curl' '--enable-dbx' '--with-imap-ssl' '--with-zlib=/usr' '--with-zlib-dir=/usr' '--with-sablot=/usr' '--enable-xslt' '--with-xslt-sablot' '--with-xmlrpc' '--enable-wddx' '--with-xml' '--enable-mbstring=all' '--enable-mbregex' '--with-bz2=/usr' '--with-crack=/usr' '--with-cdb' '--enable-pcntl' '--enable-bcmath' '--enable-calendar' '--enable-dbase' '--enable-filepro' '--enable-ftp' '--with-mime-magic=/usr/share/misc/file/magic.mime' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--with-iconv' '--enable-shmop' '--enable-dio' '--enable-yp' '--without-ncurses' '--without-readline' '--enable-inline-optimization' '--enable-track-vars' '--enable-trans-sid' '--enable-versioning' '--with-config-file-path=/etc/php/apache2-php4' '--without-pear'
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php/apache2-php4/php.ini
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
Debug Build no
Thread Safety disabled
Registered PHP Streams php, http, ftp, https, ftps, compress.bzip2, compress.zlib

Zend logo This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
Re: several errors in fudforum [message #21477 is a reply to message #21464] Wed, 01 December 2004 10:45 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you try running theme rebuild from the forum admin control panel and see if that fixes the problem?

FUDforum Core Developer
Re: several errors in fudforum [message #21533 is a reply to message #21477] Thu, 02 December 2004 11:02 Go to previous messageGo to next message
eisy is currently offline  eisy   Germany
Messages: 6
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I tried to rebuild the theme before and now once again, but it does not help. Sorry.
Re: several errors in fudforum [message #21555 is a reply to message #21533] Fri, 03 December 2004 09:57 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Can you make sure you have up to date forum source files and no file is partially checked out. The syncronize forum sources (via the forum's admin control panel) and rebuild the theme.

FUDforum Core Developer
Re: several errors in fudforum [message #21556 is a reply to message #21555] Fri, 03 December 2004 11:57 Go to previous messageGo to next message
eisy is currently offline  eisy   Germany
Messages: 6
Registered: November 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I made a 'cvs up' in egroupware/fudforum
Then syncronized sources in admin application and rebuilt theme... the error still exists... I'm sorry to bother you so hard...
Re: several errors in fudforum [message #21872 is a reply to message #21446] Wed, 22 December 2004 05:24 Go to previous message
flensje is currently offline  flensje   Netherlands
Messages: 7
Registered: December 2004
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi,

I noticed that eisy had the same problem which I'm running into.

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in C:\Program Files\Apache Group\Apache2\htdocs\egroupware\fudforum\588136416\theme\default\post.php on line 3784

Is there a solution to this problem?
I got the sources from CVS and checked the consistancy which all looked fine.
I just started with PHP and Egroupware, so this might be a simple problem.
Thanks in advance,
Daan
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: eGW maillist.php error
Next Topic: VFS Support
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Oct 21 01:08:13 EDT 2017

Total time taken to generate the page: 0.00782 seconds