FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » FUDforum in eGroupWare » Tree view not displaying for messages
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Tree view not displaying for messages [message #23600] Wed, 23 March 2005 17:04 Go to next message
Robert is currently offline  Robert   United States
Messages: 9
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have a perplexing problem. The "tree view" option is being displayed for my topics view but not my messages. When I open the topic list of the forum, a "tree view" button is displayed. However, when I select a particular topic and view the messages that have multiple message threads, no "tree view" button is displayed. Below are my fudForum eGw setting:

(Admin) Allow Tree View of Thread Listing: Yes
(Admin) Default Topic View: Flat thread listing / tree message listing
(Personal) Default Topic View: Flat view message and topic listing

The very strange thing is if I change my personal preferences to...

(Personal) Default Topic View: Tree view message and topic listing

and I then open a message, I get an error message stating "Disabled feature. This feature has been disabled by the system administrator". However, the only setting I know of that would disable the tree view thread (for topics) is set to allow it to be displayed.

Has anyone encountered a similar problem?
Re: Tree view not displaying for messages [message #23632 is a reply to message #23600] Thu, 24 March 2005 11:43 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
check the value of the "Disable Tree View of Message Listing" option.

FUDforum Core Developer
Re: Tree view not displaying for messages [message #23635 is a reply to message #23632] Thu, 24 March 2005 13:04 Go to previous messageGo to next message
Robert is currently offline  Robert   United States
Messages: 9
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have searched the admin and personal preferences for fudforum eGw and only found the setting "Allow Tree View of Thread Listing". I have set this to "yes".

Embarassed I'm a little embarassed. I have not been able to find a setting called "Disable Tree View of Message Listing". Is this option availble in fudFourm eGw? I've clicked every link and reviewed the globabl.php file. I can't seem to find it.
Re: Tree view not displaying for messages [message #23643 is a reply to message #23635] Thu, 24 March 2005 18:04 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
There is a bug in the name of the option in EGW.

You need to disable the "Disable ignore user functionality." option and the error will go away.




FUDforum Core Developer
Re: Tree view not displaying for messages [message #23648 is a reply to message #23643] Thu, 24 March 2005 20:47 Go to previous messageGo to next message
Robert is currently offline  Robert   United States
Messages: 9
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Disable Ignore User: is set to "yes" however, I am unable to see the tree view button for messages
Re: Tree view not displaying for messages [message #23664 is a reply to message #23648] Fri, 25 March 2005 14:27 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try setting it to NO.

FUDforum Core Developer
Re: Tree view not displaying for messages [message #23702 is a reply to message #23664] Sat, 26 March 2005 14:48 Go to previous messageGo to next message
Robert is currently offline  Robert   United States
Messages: 9
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user

I have set the option "Disable Ignore User:" to both "yes" and "no" and the tree view does not show for messages.

I have my eGw site set up for multipule domains. As a test, I created a fudforum under a new domain and the "tree view" button displays properly. When I set the option "Disable Ignore User:" to "yes" in this new forum, the "tree view" disappears. When I set it to "no" it reappears. However, nn my already existing domain when I change this setting, it has no effect.
Re: Tree view not displaying for messages [message #23761 is a reply to message #23702] Mon, 28 March 2005 11:26 Go to previous message
Robert is currently offline  Robert   United States
Messages: 9
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I deleted the forum and all of the data from the applications area and reinstalled fudForum eGw. This fixed the problem. I could delete all forum data since the forum was being used for testing purposes only. If the same problem occurs in the future, I probably will not have the option of removing fudforum since the site will be part of a live environment in a few days.

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: FUDforum setup within egroupware
Next Topic: threads and posts are mixed up
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Dec 15 01:35:44 EST 2017

Total time taken to generate the page: 0.00704 seconds