FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...."
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...." [message #26665] Sun, 31 July 2005 06:06 Go to next message
pozmu is currently offline  pozmu   Poland
Messages: 14
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi

I'm trying to upgrade 2.6.13 to the newest 2.6.15. I tried both upgrade.php versions (with zlib and without). All I get is a red message:
Quote:

Failed to parse GLOBALS.php at "/home/pozmu/www/fudfurum/GLOBALS.php" correctly
.
What can be wrong??? I even tried with other GLOBALS.php from other server but the result is the same Sad I even tried upgrading to 2.6.14 but nothing changes... HELP ME PLEASE! Thanks in advance
Re: Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...." [message #26666 is a reply to message #26665] Sun, 31 July 2005 10:37 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you manually modified this file and does it contain the COOKIE_NAME variable?

FUDforum Core Developer
Re: Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...." [message #26668 is a reply to message #26665] Sun, 31 July 2005 11:11 Go to previous messageGo to next message
pozmu is currently offline  pozmu   Poland
Messages: 14
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Yes, I manually edited this file.
COOKIE_NAME = "fud_session_1120033782"
Re: Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...." [message #26669 is a reply to message #26668] Sun, 31 July 2005 11:17 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Make sure that each line defining a variable is terminated by a semi-colon.

FUDforum Core Developer
Re: Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...." [message #26670 is a reply to message #26665] Sun, 31 July 2005 11:35 Go to previous messageGo to next message
pozmu is currently offline  pozmu   Poland
Messages: 14
Registered: March 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Yes, it is. As I said before, I even tried to use GLOBALS.PHP from other server - this one was generated automatically by install script and it doesn't work too Sad

But maybe it failed becouse I installed something wrong (I was installing it manually). Upgrade works with script installed by install script... so you can close this topic, sorry for confusion.
Re: Can't upgrade FUDforum 2.6.13 - "Failed to parse GLOBALS.php at...." [message #26672 is a reply to message #26670] Sun, 31 July 2005 12:20 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Well, try adding debug code to the upgrade script, the error you are seeing is due to the script parsing the GLOBALS.php and for some reason failing to create the expected variables.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: HELP - Can't even start Installation
Next Topic: zlib version seems to decompress...
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Oct 18 16:35:04 EDT 2017

Total time taken to generate the page: 0.00658 seconds