FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » General » FUDforum in eGroupWare » Fatal SQL error when posting
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Fatal SQL error when posting [message #26845] Wed, 17 August 2005 05:01 Go to next message
Kagex is currently offline  Kagex   Singapore
Messages: 4
Registered: August 2005
Location: Singapore
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have just set up egw1.0.0.009 clean. Fudforum setup is fine. No errors. However, i couldn't see any threads i have newly created when I'm inside the forum. There is no new topics. but i could see the the new post counts on the main page. I could also see all the topics i have previously created when i click on the "unread posts" link.

I have tried using localhost and other client machines to create new topics. both came out with the same errors. Login user was admin.

I'm running egw1.0.0.009 on Win2k3_SP1 with IIS6 as my http server. Database used is mysql4.1.13-nt via tcp/ip. PHP is 5.0.4 in CGI mode.

Access rights for egroupware is set to read and execute, whereas fudforum and files folder set to read, execute and write.

Below are the errors encounter with and without php_decode...

Fatal error: SQL Error has occurred, please contact the administrator of the forum and have them review the forum's SQL query log in C:\Inetpub\wwwroot\egroupware\fudforum\3814588639\index.php on line 71



(C:\Inetpub\wwwroot\egroupware\fudforum\3814588639\index.php:131
C:\Inetpub\wwwroot\egroupware\fudforum\3814588639\theme\default\post.php:28 05
C:\Inetpub\wwwroot\egroupware\fudforum\3814588639\theme\default\post.php:16 68
C:\Inetpub\wwwroot\egroupware\fudforum\3814588639\theme\default\post.php:37 51
C:\Inetpub\wwwroot\egroupware\fudforum\3814588639\index.php:412
) 1062: Duplicate entry '1-2147483645-0' for key 1
Query: INSERT INTO phpgw_fud_thread_view (thread_id,forum_id,page,tmp) SELECT phpgw_fud_thread.id, phpgw_fud_thread.forum_id, 2147483645, CASE WHEN thread_opt>=2 AND (phpgw_fud_msg.post_stamp+phpgw_fud_thread.orderexpiry>1124268245 OR phpgw_fud_thread.orderexpiry=0) THEN 4294967294 ELSE phpgw_fud_thread.last_post_date END AS sort_order_fld FROM phpgw_fud_thread INNER JOIN phpgw_fud_msg ON phpgw_fud_thread.root_msg_id=phpgw_fud_msg.id WHERE forum_id=1 AND phpgw_fud_msg.apr=1 ORDER BY sort_order_fld DESC, phpgw_fud_thread.last_post_id DESC
Server Version: 4.1.13-nt
[Referring Page] http://192.168.253.13/egroupware/fudforum/3814588639/index.php?t=post&f rm_id=1&
Re: Fatal SQL error when posting [message #26989 is a reply to message #26845] Wed, 24 August 2005 03:02 Go to previous message
Kagex is currently offline  Kagex   Singapore
Messages: 4
Registered: August 2005
Location: Singapore
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Found the problem. Mysql was running innodb. Changed to MyIsam and works fine.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Url links don't work
Next Topic: Deleting Users in ewg
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 12 13:03:59 EST 2017

Total time taken to generate the page: 0.00738 seconds