Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Finally Solved: Directory exists but the webserver has no permission
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Finally Solved: Directory exists but the webserver has no permission [message #27617] Thu, 15 September 2005 16:03
paddler is currently offline  paddler   United States
Messages: 1
Registered: September 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
If your getting this message:
The 'files/' (/files) directory exists, however webserver has no write permissions to that directory

Keep reading.

I know I have seen this error bantered around for a while and I could never get an answer I understood. Finally today I figured out how to set up the path correctly in egroupware.

People keep saying to put the folder above the web root and give it permissions. I did that over and over again. Checked my configuration file and never saw what was wrong. Until I started thinking about how the server would know that folder existed and how to get there.

In the egroupware configuration where it says what is the folder for the group files: enter the absolute path to the files.

I was using the relative path.

In my installation on a shared/hosted server my path is /home/~username/egroupfiles

Create the folder above public_html or in the same folder as it is. In other words when you log into your account you will see the folder public_html and in the same directory/folder create your egroupfile (or whatever you call it) folder. This will be the top level folder location, you will be able to go no higher in the folder hierachy.

Then make sure the folder has 777 permissions.

Check your egroupware configuration and enter the absolute path to this folder.

Not only did fudforum start working but so did my file manager.

I am a little thick sometimes and in all the reading I never had any one say "use the absolute path" to the folder.

I hope this helps anyone out there.

[Updated on: Thu, 15 September 2005 16:29]

Report message to a moderator

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Incorrect number of lines in Topic List
Next Topic: New Messege Post
Goto Forum:

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Mar 26 14:58:09 EDT 2019

Total time taken to generate the page: 0.00621 seconds