FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Problem with mailingslistmanager
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Problem with mailingslistmanager [message #27857] Wed, 28 September 2005 14:28 Go to next message
nelius is currently offline  nelius   Germany
Messages: 5
Registered: September 2005
Location: Germany
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi

i'm not able to use the mailinglist-manager.
This is what i did:

i set up a forum and a emailadress for the mailinglist.
i set up the mailinglist rule and added a line into
/etc/postfix/aliases:
"fud-developers: "|/var/www/html/forum/scripts/maillist.php 1"

If i now send a message to the adress (@egroupware.org) the mail gets bounced with the following in the logs:

to=<@egroupware.org>, relay=local, delay=1, status=bounced (Command died with status 255: "/var/www/html/forum/scripts/maillist.php 1")



question: The mailinglist address (which i typed into the maillinglist form) is @lists.sourcefore.net. But the mails are send from egroupware-developers-admin(at)lists(dot)sourceforge(dot)net. is this a problem?

[Updated on: Thu, 29 September 2005 06:10]

Report message to a moderator

Re: Problem with mailingslistmanager [message #27858 is a reply to message #27857] Wed, 28 September 2005 16:04 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try to modify the execution line to say:

php /var/www/html/forum/scripts/maillist.php 1


FUDforum Core Developer
Re: Problem with mailingslistmanager [message #27859 is a reply to message #27858] Wed, 28 September 2005 16:26 Go to previous messageGo to next message
nelius is currently offline  nelius   Germany
Messages: 5
Registered: September 2005
Location: Germany
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ther errormessage changes form :
Sep 28 20:12:25 server postfix/local[28935]: 37F8C50017: to=<@egroupware.org>, relay=local, delay=1, status=bounced (Command died with status 255: "/var/www/html/forum/scripts/maillist.php 1")

to:
Sep 28 22:21:41 server postfix/local[4214]: A0FAD50017: to=<@egroupware.org>, relay=local, delay=1, status=bounced (Command died with status 255: "php /var/www/html/forum/scripts/maillist.php 1". Command output: Content-type: text/html_ _ )

Sad

btw: On the console it is running. if i do
cat mail.txt |/var/www/html/forum/scripts/maillist.php 1
the mail comes into the forum

[Updated on: Thu, 29 September 2005 06:09]

Report message to a moderator

Re: Problem with mailingslistmanager [message #27866 is a reply to message #27859] Wed, 28 September 2005 18:46 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Add -q flag to PHP, you seem to have php-cgi installed.

What user does the process runs as when it succeeds (command line) vs when it runs via procmail?


FUDforum Core Developer
Re: Problem with mailingslistmanager [message #27881 is a reply to message #27857] Thu, 29 September 2005 03:29 Go to previous messageGo to next message
nelius is currently offline  nelius   Germany
Messages: 5
Registered: September 2005
Location: Germany
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Sep 29 09:25:53 server postfix/local[13777]: 27BF250017: to=<@egroupware.org>, relay=local, delay=0, status=bounced (Command died with status 255: "php -q /var/www/html/forum/scripts/maillist.php 1")

It succeeds (command line) as root, but NOT as normal user.
The mailserver runs as postfix user

Ok, i got it, i need to unlock the forum files all the time, cause otherwise the maillist-script can't be run.

but if i do so and send a message now, it's deleivert to the script, a new user is created to the forum, but the message isn't shown in the forum...

[Updated on: Thu, 29 September 2005 06:09]

Report message to a moderator

Re: Problem with mailingslistmanager [message #27884 is a reply to message #27881] Thu, 29 September 2005 06:08 Go to previous messageGo to next message
nelius is currently offline  nelius   Germany
Messages: 5
Registered: September 2005
Location: Germany
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok, it's running now.

i had to chown ~/messages/*
cause this had wrong permissions from my commandline test as root

tnx for your help Ilia!!!
Re: Problem with mailingslistmanager [message #27897 is a reply to message #27884] Thu, 29 September 2005 11:59 Go to previous messageGo to next message
nelius is currently offline  nelius   Germany
Messages: 5
Registered: September 2005
Location: Germany
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi Ilia,

2 more problems:

Ther serious one:
If i write a post in the forum, a mail like the following is sent to the list:
Mime-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: BASE64

SGF2ZSBhIGxvb2sgaW50byB0aGUgYWRtaW4tcGFubmVsClRoZSBmaXJzdCBwb2ludCBpcyAtPnN p
dGUgY29uZmlndXJhdGlvbjwtCgpUaGVyZSBsb29rIGluIHRoZSAzJ3JkIHRvcGljIHdoaWNoIGl z
ICJzZWN1cml0eSIKClRoZSAzJ3JkIGl0ZW0gaW4gdGhpcyB0b3BpYyBpcyB3aGF0IHlvdSBhcmU g
bG9va2luZyBmb3IgLi4uCgpodGgKY3UKY29ybmVsaXVz


the less serious one:
For each ml a file in messages/ is created with mod 600 form the user of the mailserver. Thus the mailserver can't read the file.
Re: Problem with mailingslistmanager [message #27900 is a reply to message #27897] Thu, 29 September 2005 13:50 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to unlock the forum's files via the admin control panel. Then this won't be a problem.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: I guess this is something simple -- FLAT VIEW
Next Topic: NNTP Bug in 2.72/2.73RC1
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Oct 16 18:19:17 EDT 2017

Total time taken to generate the page: 0.00705 seconds