FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrade problems
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrade problems [message #27921] Fri, 30 September 2005 14:56 Go to next message
cstdenis is currently offline  cstdenis   Canada
Messages: 17
Registered: April 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I tried to upgrade my forum from 2.6x to v2.7.2.

Because I use a view of my user's table, the upgrade didn't go so well (alter table + views = fatal errors). With some hacking of the upgrade script, I was able to get it to skip the queries on my users table which I then ran manually and everything looks like it completed successfully.

However, now if I try to reindex the DB I get this error
Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /usr/home/cstdenis/anime_vidcaps_forums/include/theme/default/db.inc on line 244
(/usr/home/cstdenis/anime_vidcaps_forums/include/theme/default/db.inc:226
/usr/home/cstdenis/anime_vidcaps_forums/include/theme/default/isearch.inc:116
/usr/home/cstdenis/www/fanart/anime-vidcaps/forums/adm/indexdb.php:75
) : ERROR: current transaction is aborted, commands ignored until end of transaction block
Query: INSERT INTO fud26_title_index (word_id, msg_id) SELECT id, 1 FROM fud26_search WHERE word IN('Anime','Vidcaps','has','new','forum')
_POST: array ( 'conf' => 'Yes', 'SQ' => 'ec4e5de98de427ccf9e07e2bc8a7dfbd', )
Server Version: 


And, if I try to do a consistency check, I get this error:
Warning: pg_query() [function.pg-query]: Query failed: ERROR: relation "fud26_attach_up" does not exist in /usr/home/cstdenis/anime_vidcaps_forums/include/theme/default/db.inc on line 102
(/usr/home/cstdenis/anime_vidcaps_forums/include/theme/default/db.inc:102
/usr/home/cstdenis/anime_vidcaps_forums/include/theme/default/db.inc:63
/usr/home/cstdenis/www/fanart/anime-vidcaps/forums/adm/consist.php:152
) : ERROR: relation "fud26_attach_up" does not exist
Query: LOCK TABLE fud26_action_log, fud26_ann_forums, fud26_announce, fud26_attach_up, fud26_avatar, fud26_blocked_logins, fud26_buddy, fud26_cat, fud26_custom_tags, fud26_email_block, fud26_ext_block, fud26_fc_view, fud26_forum, fud26_fl_1, fud26_forum_notify, fud26_forum_read, fud26_group_cache, fud26_group_members, fud26_group_resources, fud26_groups, fud26_index, fud26_ip_block, fud26_level, fud26_mime, fud26_mlist, fud26_mod, fud26_mod_que, fud26_msg, fud26_msg_report, fud26_nntp, fud26_ses, fud26_pmsg, fud26_fl_pm, fud26_poll, fud26_poll_opt, fud26_poll_opt_track, fud26_read, fud26_replace, fud26_stats_cache, fud26_search, fud26_search_cache, fud26_smiley, fud26_themes, fud26_thr_exchange, fud26_thread, fud26_thread_notify, fud26_thread_rate_track, fud26_title_index, fud26_user_ignore, fud26_fl_2, fud26_fl_3, fud26_fl_4, fud26_fl_5, fud26_fl_14, fud26_fl_6, fud26_fl_7, fud26_fl_8, fud26_fl_9, fud26_fl_10, fud26_fl_11, fud26_fl_12, fud26_fl_13, fud26_tv_14, fud26_tv_5, fud26_tv_8, fud26_tv_7, fud26_tv_9, fud26_tv_3, fud26_tv_10, fud26_tv_6, fud26_tv_2, fud26_tv_12, fud26_tv_1, fud26_tv_11, fud26_tv_4, fud26_tv_13,fud26_users,fud26_forum,fud26_thread,fud26_poll,fud26_poll_opt,fud26_poll_opt_track,fud26_msg,fud26_pmsg,fud26_mod,fud26_thread_rate_track,fud26_msg_report,fud26_cat,fud26_forum_notify,fud26_thread_notify,fud26_buddy,fud26_user_ignore,fud26_msg,fud26_msg,fud26_users,fud26_users,fud26_attach,fud26_thr_exchange,fud26_read,fud26_mime,fud26_group_members,fud26_group_resources,fud26_groups,fud26_group_members,fud26_group_members,fud26_themes IN ACCESS EXCLUSIVE MODE
_POST: array ( 'conf' => 'Yes', 'SQ' => 'ec4e5de98de427ccf9e07e2bc8a7dfbd', )
Server Version:

After digging through the code and upgrade script, I can't find any references to fud26_attach_up.



Also, I just accidentally closed the window and its no longer accepting my admin login. It doesn't reject it, but it does go back to the "Undergoing maintenance, please come back later." screen after I type it in.
Re: Upgrade problems [message #27924 is a reply to message #27921] Fri, 30 September 2005 15:34 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
What database backend are you using, is it PostgreSQL by any chance?

FUDforum Core Developer
Re: Upgrade problems [message #27925 is a reply to message #27921] Fri, 30 September 2005 15:56 Go to previous messageGo to next message
cstdenis is currently offline  cstdenis   Canada
Messages: 17
Registered: April 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Yes, its postgres
Re: Upgrade problems [message #27958 is a reply to message #27921] Mon, 03 October 2005 11:30 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The search indexing query has been fixed in CVS. As far as the "ERROR: relation "fud26_attach_up" does not exist" error. Can you check your PostgreSQL schema and see what it is that you have that has this name.

FUDforum Core Developer
Re: Upgrade problems [message #27969 is a reply to message #27921] Mon, 03 October 2005 14:19 Go to previous messageGo to next message
cstdenis is currently offline  cstdenis   Canada
Messages: 17
Registered: April 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
As the error suggests, fud26_attach_up does not exist. There is no such table, view, schema, sequence, etc.

On a possably related note, I see a bunch of oddly nameds tables fud26_fl_1...fud26_fl_14 and fud26_tv_1...fud26_tv_14
Re: Upgrade problems [message #27970 is a reply to message #27969] Mon, 03 October 2005 14:43 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Those tables are ok, they are intentional. The fud26_attach_up I don't know about...

Try running
SELECT * FROM pg_class WHERE relname='fud26_attach_up'
query and see what you get.


FUDforum Core Developer
Re: Upgrade problems [message #27979 is a reply to message #27921] Mon, 03 October 2005 22:15 Go to previous messageGo to next message
cstdenis is currently offline  cstdenis   Canada
Messages: 17
Registered: April 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
that query returns 0 rows

----

SELECT relname, relkind FROM pg_class where relowner=102 and relname not like 'phpbb_%' and relname not like 'pg_%' and (relkind = 'r' or relkind = 'v') ;

"fud26_action_log";"r"
"fud26_ann_forums";"r"
"fud26_announce";"r"
"fud26_attach";"r"
"fud26_users_up";"r"
"fud26_avatar";"r"
"fud26_blocked_logins";"r"
"fud26_buddy";"r"
"fud26_cat";"r"
"fud26_custom_tags";"r"
"fud26_email_block";"r"
"fud26_ext_block";"r"
"fud26_fc_view";"r"
"fud26_forum";"r"
"fud26_fl_1";"r"
"fud26_forum_notify";"r"
"fud26_forum_read";"r"
"fud26_group_cache";"r"
"fud26_group_members";"r"
"fud26_group_resources";"r"
"fud26_groups";"r"
"fud26_index";"r"
"fud26_ip_block";"r"
"fud26_level";"r"
"fud26_users";"v"
"fud26_mime";"r"
"fud26_mlist";"r"
"fud26_mod";"r"
"fud26_mod_que";"r"
"fud26_msg";"r"
"fud26_msg_report";"r"
"fud26_nntp";"r"
"fud26_ses";"r"
"fud26_pmsg";"r"
"fud26_fl_pm";"r"
"fud26_poll";"r"
"fud26_poll_opt";"r"
"fud26_poll_opt_track";"r"
"fud26_read";"r"
"fud26_replace";"r"
"fud26_stats_cache";"r"
"fud26_search";"r"
"fud26_search_cache";"r"
"fud26_smiley";"r"
"fud26_themes";"r"
"fud26_thr_exchange";"r"
"fud26_thread";"r"
"fud26_thread_notify";"r"
"fud26_thread_rate_track";"r"
"fud26_title_index";"r"
"fud26_user_ignore";"r"
"fud26_fl_2";"r"
"fud26_fl_3";"r"
"fud26_fl_4";"r"
"fud26_fl_5";"r"
"fud26_fl_14";"r"
"fud26_fl_6";"r"
"fud26_fl_7";"r"
"fud26_fl_8";"r"
"fud26_fl_9";"r"
"fud26_fl_10";"r"
"fud26_fl_11";"r"
"fud26_fl_12";"r"
"_fud26_users";"r"
"fud26_fl_13";"r"
"fud26_tv_14";"r"
"fud26_tv_5";"r"
"fud26_tv_8";"r"
"fud26_tv_7";"r"
"fud26_tv_9";"r"
"fud26_tv_3";"r"
"fud26_tv_10";"r"
"fud26_tv_6";"r"
"fud26_tv_2";"r"
"fud26_tv_12";"r"
"fud26_tv_1";"r"
"fud26_tv_11";"r"
"fud26_tv_4";"r"
"fud26_tv_13";"r"

fud26_users is a view of _fud26_users and another table in another schema.
Re: Upgrade problems [message #27986 is a reply to message #27979] Tue, 04 October 2005 09:33 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try this patch:
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7367


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Fudforum in phpgroupware missing buttons at top of page.
Next Topic: New Install of 2.7.2 fails
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Oct 17 09:17:25 EDT 2017

Total time taken to generate the page: 0.00660 seconds