FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Internal Server Error
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Internal Server Error [message #28051] Sun, 09 October 2005 05:53 Go to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hi,

I've tried to upgrade my forum to the latest stable release but am experiencing some problems.

When trying to run the upgrade.php schript I'm getting the following error message:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.


After performing this action, the forum does not function anymore. When staring the forum (or forum administrator) I'm getting the same message.

When checking the files, I've noticed that the GLOBALS.php file has been changed as the modification date was changed.

I remember a similar situation a while ago, when also trying to upgrade. Somehow, after a number of days, the forum was suddenly functioning again.

I appreciate your help, many thanks.

Regards,
Patrick



Re: Internal Server Error [message #28080 is a reply to message #28051] Mon, 10 October 2005 11:10 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
How are you running your PHP and what version of PHP are you using?

FUDforum Core Developer
Re: Internal Server Error [message #28083 is a reply to message #28080] Mon, 10 October 2005 11:39 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hi Ilia,

The Forum is running on my domain, hosted by a service provider. (Ensim is used)

PHP Version is: 4.3.10

(Please see private message for site details)

Regards,
Patrick
Re: Internal Server Error [message #28110 is a reply to message #28083] Tue, 11 October 2005 11:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try raising the memory limit or downloading the zlib compressed upgrade script.

FUDforum Core Developer
Re: Internal Server Error [message #28113 is a reply to message #28110] Tue, 11 October 2005 12:00 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia,

But why does my existing forum not work anymore?
The upgrade did not run???

Patrick
Re: Internal Server Error [message #28114 is a reply to message #28110] Tue, 11 October 2005 12:03 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I did use the zlib compressed upgrade script.

I am not able to change any PHP settings.

Regards,
Patrick
Re: Internal Server Error [message #28125 is a reply to message #28114] Tue, 11 October 2005 19:10 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Have you checked the error log files inside the errors directory?

FUDforum Core Developer
Re: Internal Server Error [message #28134 is a reply to message #28125] Wed, 12 October 2005 06:16 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia,

I've checked error_log files in the the /var/log/httpd directory.
Here I find the error:

Premature end of script headers: php-script


I'm not able to start any PHP app from this directory. I've placed a small info.php app, which basically returns the PHP settings. This gives the same error????

I remember a similar situation a while ago, when also trying to upgrade. Somehow, after a number of days, the forum was suddenly functioning again.

Does it have anutging to do with the GLOBALS.PHP file???

Patrick

[Updated on: Wed, 12 October 2005 06:34]

Report message to a moderator

Re: Internal Server Error [message #28138 is a reply to message #28134] Wed, 12 October 2005 09:26 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It looks like your PHP is crashing, which is usually indicative of this type of error. What PHP are you running?

FUDforum Core Developer
Re: Internal Server Error [message #28154 is a reply to message #28138] Wed, 12 October 2005 11:22 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
PHP Version 4.3.10

Please run:

http://www.vanhooijdonk.net/info.php

This will give you the PHP settings.

I've copied the info.php to the forum dir. When executing, i'll get the same error message.

http://www.vanhooijdonk.net/forum/info.php

Thanks,
Patrick

[Updated on: Wed, 12 October 2005 11:22]

Report message to a moderator

Re: Internal Server Error [message #28158 is a reply to message #28154] Wed, 12 October 2005 12:22 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I think I see the problem. Remove the .htaccess file inside the forum's web root dir.

FUDforum Core Developer
Re: Internal Server Error [message #28159 is a reply to message #28158] Wed, 12 October 2005 12:58 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia,

This file was already deleted.

It does exist in other dirs and forum_data sub-dirs
Should I delete those?

Patrick
Re: Internal Server Error [message #28165 is a reply to message #28159] Wed, 12 October 2005 16:24 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Just removing that one should be enough.

FUDforum Core Developer
Re: Internal Server Error [message #28186 is a reply to message #28165] Thu, 13 October 2005 04:10 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia,

The file was already deleted.

Patrick
Re: Internal Server Error [message #28196 is a reply to message #28186] Thu, 13 October 2005 11:55 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
And the error still persists? Have you check permissions of the forum's main dir?

FUDforum Core Developer
Re: Internal Server Error [message #28201 is a reply to message #28196] Thu, 13 October 2005 12:11 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
That is 777
Re: Internal Server Error [message #28259 is a reply to message #28196] Sat, 15 October 2005 06:57 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Ilia,

The permissions of the forum's main dir is 777.

Any other idea's?
Re: Internal Server Error [message #28287 is a reply to message #28259] Sat, 15 October 2005 14:42 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Any .htaccess files in the parent dir?
Have you tried chmoding the dir 755?


FUDforum Core Developer
Re: Internal Server Error [message #28291 is a reply to message #28287] Sat, 15 October 2005 16:41 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
This made a difference.

Once changing the forum dir to 755, I was able to run the info.php.
Once I changed the index.php (in the forum dir) to 755, the forum seemed to work again.

Then I tried to install the upgrade. This failed and the forum dir was set back to 777. The forum did not work anymore.

I've changed the forum dir to 755 again, set the upgrade.php to 755. The upgrade worked fine, but the cons. check did not start. I've then changed all files/sub-files to 755 and could run the cons. check .

The only problem now .... it seems that all body content has disappeared ????? Sad
Re: Internal Server Error [message #28310 is a reply to message #28291] Mon, 17 October 2005 10:45 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It seems like your virtual host is setup in such a way that 777 dirs are made non-web browseable, hence the error you were seeing. As far as the body content, check the messages/ directory and make sure it is readable by the forum and so are its contents.

FUDforum Core Developer
Re: Internal Server Error [message #28335 is a reply to message #28310] Tue, 18 October 2005 13:10 Go to previous messageGo to next message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
Hi Ilia,

I see what you mean.
I have checked the messages directory and noticed that the msg_80000 file is only 12 bytes. It seems that all content is gone.

The problems with the forum started about a year ago. My provider moved my Domain from a server in the US to a server in The Netherlands. The US server was running in Safe Mode. The Dutch server is not. After the move, I have not been able to do any upgrades.

I'm starting from scratch now Smile At least a clean environment.

Thanks for the help!!

Patrick
Re: Internal Server Error [message #28336 is a reply to message #28335] Tue, 18 October 2005 13:31 Go to previous message
patrick is currently offline  patrick   Netherlands
Messages: 103
Registered: September 2002
Karma: 0
Senior Member
add to buddy list
ignore all messages by this user
I did notice that when 'unlocking' the forum, the Internal Server Error appears again.

I had to do a chmod 755 on the forum dir/files in order run the forum again. After 'locking' again all seems fine again.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Cannot connect to MySQL
Next Topic: Adding own header/footer
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Sat Sep 22 18:59:05 EDT 2018

Total time taken to generate the page: 0.01018 seconds