FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum Development » Plugins and Code Hacks » extra line breaks and anchors when editing/quoting mailing list posts
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
extra line breaks and anchors when editing/quoting mailing list posts [message #28188] Thu, 13 October 2005 06:39
tymp is currently offline  tymp   United States
Messages: 13
Registered: July 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hallo,

Not sure if this is a bug report or a "patch".

I was having this problem with editing and quoting posts from a synchronized mailing list, with FUDforum version 2.6.13:
- messages from a mailing list, when edited or quoted, contained extra html break tags and anchor tags.

Adding the following at line 187 in post.inc.t (after the block/clause 'else if ($reply_to || $th_id)'):
$msg_body = eregi_replace( "<a[^>]*>([^<]*)</a>", "\\1", $msg_body);
$msg_body = eregi_replace( "<br[^>]*>", "", $msg_body);
seems to have resolved this...

So, i don't know how good or bad a solution this is, and not sure if it will cause other problems... but i think the problem is a bug.. and this is a start to a fix, at least (also, i didn't search the forum for previous fixes to this because... i'm in a rush).

Cheers,
-rob
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Mailing List Functionality w/crontab, instead of .procmailrc or .forward
Next Topic: Alternative mailing list message gateway
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Wed Oct 18 21:59:53 EDT 2017

Total time taken to generate the page: 0.00674 seconds