FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Upgrade to 2.7.3 error
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Upgrade to 2.7.3 error [message #28557] Mon, 31 October 2005 10:59 Go to next message
keneisman is currently offline  keneisman   United States
Messages: 68
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
Upgrading to 2.7.3 from 2.6.14 I get the following:

Checking if SQL permissions to perform the upgrade are avaliable
Disable the forum
Forum is now disabled
Beginning the file upgrade process
Begining to decompress the archive
Finished decompressing the archive
File Upgrade Complete
Any changed files were backed up to: "c:/GEMSforum/errors/.backup/"

Beginning SQL Upgrades
SQL Upgrades Complete
Setting default theme

Notice: Undefined index: LANGUAGE in c:\Inetpub\wwwroot\gemsforum\upgrade.php on line 1301

Notice: Undefined index: LOCALE in c:\Inetpub\wwwroot\gemsforum\upgrade.php on line 1301
Adding GLOBAL Variables
Compiling theme default

Warning: file_get_contents(c:/GEMSforum/thm/default/i18n//charset) [function.file-get-contents]: failed to open stream: No such file or directory in c:\GEMSforum\include\compiler.inc on line 613
Missing Message entry custom_avatar_queue inside i18n//msg

*******************************************************

Now, if I try to get to the forum, I just get a blank page. If I try to run the upgrade script again, my admin login no longer works.

Running on W2k3 server
MySQL database

Thanks for any help
Ken

[Updated on: Mon, 31 October 2005 11:06]

Report message to a moderator

Re: Upgrade to 2.7.3 error [message #28576 is a reply to message #28557] Mon, 31 October 2005 18:27 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Run the fixed upgrade script from here:
http://bb.prohost.org/fud21_upgrade/upgrade.php.tar.gz


FUDforum Core Developer
Re: Upgrade to 2.7.3 error [message #28577 is a reply to message #28576] Mon, 31 October 2005 18:35 Go to previous messageGo to next message
ortizdr is currently offline  ortizdr   United States
Messages: 2
Registered: October 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Ok i have a similar problem except that I am getting this error message at the bottom of all my forums:

(D:\FUDforum\index.php:220
D:\FUDforum\index.php:1090
D:\FUDforum\theme\default\thread.php:618
D:\FUDforum\index.php:1219
) : ERROR: duplicate key violates unique constraint "fud26_forum_read_i_fu"
Query: INSERT INTO fud26_forum_read (forum_id, user_id, last_view) VALUES (5, 3, 1130801064)
_GET: array ( 't' => 'thread', 'frm_id' => '5', 'S' => '6279ed323449309eb8adca1a57f577a9', )
Server Version:
[Referring Page] http://dusnet.servehttp.com:81/fudforum/


Most of the posts are messed up. I have tried running Forum Consistancy Checker, SQL Optimization, Rebuild The Search Index, and Compact Messages. Any info. would be awesome!!
Re: Upgrade to 2.7.3 error [message #28579 is a reply to message #28577] Mon, 31 October 2005 18:49 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It looks like your mysql does not return error information, hence this problem.

FUDforum Core Developer
Re: Upgrade to 2.7.3 error [message #28581 is a reply to message #28576] Mon, 31 October 2005 18:55 Go to previous messageGo to next message
keneisman is currently offline  keneisman   United States
Messages: 68
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ilia wrote on Mon, 31 October 2005 17:27

Run the fixed upgrade script from here:
http://bb.prohost.org/fud21_upgrade/upgrade.php.tar.gz


Are you sure this is the right link? When I unpack it, the size is well over 4 meg where the original upgrade script was just over 1 meg. Plus, when I try to open it in my php editer, it opens in a binary type format instead of text.

Maybe I'm doing something wrong?

Thanks
Ken
Re: Upgrade to 2.7.3 error [message #28584 is a reply to message #28581] Mon, 31 October 2005 19:09 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Yes, this the uncompressed version.

FUDforum Core Developer
Re: Upgrade to 2.7.3 error [message #28593 is a reply to message #28579] Tue, 01 November 2005 00:08 Go to previous messageGo to next message
ortizdr is currently offline  ortizdr   United States
Messages: 2
Registered: October 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I use postgrese or however you say it.
Re: Upgrade to 2.7.3 error [message #28597 is a reply to message #28584] Tue, 01 November 2005 08:11 Go to previous messageGo to next message
keneisman is currently offline  keneisman   United States
Messages: 68
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
Ilia wrote on Mon, 31 October 2005 18:09

Yes, this the uncompressed version.


OK, I use the downloads with zlib compression. Does this mean I need a different upgrade script?

Even though the link says http://bb.prohost.org/fud21_upgrade/upgrade.php.tar.GZ, it downloads a file called upgrade.php.tar.TAR. (Emphasis added) I suppose my decompression utility could be faulty. It's a free download.

Thanks
Ken

[Updated on: Tue, 01 November 2005 08:15]

Report message to a moderator

Re: Upgrade to 2.7.3 error [message #28598 is a reply to message #28597] Tue, 01 November 2005 09:10 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Winzip should be able to decompress the file,there is only 1 file inside the archive. You need to extract it and run it... that's all there is to it.

FUDforum Core Developer
Re: Upgrade to 2.7.3 error [message #28601 is a reply to message #28598] Tue, 01 November 2005 12:02 Go to previous messageGo to next message
keneisman is currently offline  keneisman   United States
Messages: 68
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
WinZip will not extract it. I get an 'Error Reading Header.'

I've tried re-downloading it, to no avail.

Thanks
Ken
Re: Upgrade to 2.7.3 error [message #28608 is a reply to message #28601] Tue, 01 November 2005 16:08 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Try downloading this one:
http://bb.prohost.org/fud21_upgrade/upgrade.zip


FUDforum Core Developer
Re: Upgrade to 2.7.3 error [message #28613 is a reply to message #28608] Tue, 01 November 2005 17:32 Go to previous messageGo to next message
keneisman is currently offline  keneisman   United States
Messages: 68
Registered: May 2005
Karma: 0
Member
add to buddy list
ignore all messages by this user
I've downloaded it and unzipped it using several different programs including WinZIP. When I try to read the unzipped file with my PHP editor it shows up in hex, leading me to beleive that the file is corrupt. It is also still almost 4 times bigger than the original upgrade.php. When I try to run it, I get what appear to be php messages in my IE window but they are all mixed up and don't make sense and then I get several IE message boxes telling me that this web page wants to shut down. This is the same behavior I observed with the first file you posted in this thread.

In desperation, I've tried exporting my forum (2.6.14RC1) doing a fresh install of 2.6.14RC1 and importing into the fresh install. Hoping that the fresh install wouldn't have the corruption of the original and then I could upgrade IT to 2.7.3. However, I get an error that the action_log does not exist and another one that says one of the user's passwords in wrong. Then it bombs and I can't log in anymore.

Thanks
Ken

[Updated on: Tue, 01 November 2005 17:34]

Report message to a moderator

Re: Upgrade to 2.7.3 error [message #28633 is a reply to message #28613] Wed, 02 November 2005 17:53 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
not sure, the file included works fine on my servers...

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Can't logon to the site
Next Topic: Formatting Tools and Smiley's don't work
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Jul 17 13:40:37 EDT 2018

Total time taken to generate the page: 0.00856 seconds