FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » 2.7.2 to 2.7.3 upgrade error
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
2.7.2 to 2.7.3 upgrade error [message #28662] Fri, 04 November 2005 00:38 Go to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hey,

Thanks for the forums Smile

I have an issue upgrading from 2.7.2 to 2.7.3. When I run the upgrade.php I get:

Failed to parse GLOBALS.php at "/home/www/kmm672/html/community/GLOBALS.php" correctly

File is chmod 777 and should be fine for the upgrade script. Forums is working fine, obviously, so I'm at a loss to explain why it's not working.

The forum is configured to run in /community/ and the data dir is /community_data/. It also called from community.xx.xx and that also gives the same error msg.

suggestions / ideas?
Re: 2.7.2 to 2.7.3 upgrade error [message #28673 is a reply to message #28662] Fri, 04 November 2005 17:14 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did you manually edit the file and does it have $COOKIE_NAME var in it?

FUDforum Core Developer
Re: 2.7.2 to 2.7.3 upgrade error [message #28679 is a reply to message #28673] Fri, 04 November 2005 17:28 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I didn't modify anything.

The only thing is that I've had to manually install the forum because the install script won't work. So I install it on my local server and FTP the files over on the remote machine. Once it's there I modify the basic setup (globals.php files) and import the DB.

You'll probably want to know why it doesn't install and the quick answer to that is the hoster set the user groups in such a way that if the wwwapache modified a file's perms, that same group can't modify it back to whatever value you want. From what I could experience, that fubars the install big time.

Now, I really don't think this could be viewed as a perm problem since that file (globals.php) is 777 and is not part of the wwwapache group. It still can be modified by fudforum but it seems it only affect the perms changes. This is quite confusing, I know.

Anyway, as I was saying, I can modify the forum's settings and thus, it should work.

Sorry if I sound confused Smile
Re: 2.7.2 to 2.7.3 upgrade error [message #28680 is a reply to message #28679] Fri, 04 November 2005 17:29 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did your local install happen to have been a Windows machine?

FUDforum Core Developer
Re: 2.7.2 to 2.7.3 upgrade error [message #28684 is a reply to message #28680] Fri, 04 November 2005 22:40 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
It was but that's the only way I was able to install the forum. Each and every file has a chmod, no file is unset and all files are saved with LF only. No CR/LF are in those files. Any files modified locally are mandatorily saved in UNIX format.

Anyway, what do you think can be done about the situation?
Re: 2.7.2 to 2.7.3 upgrade error [message #28696 is a reply to message #28684] Sat, 05 November 2005 16:29 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
The problem is that GLOBALS.php file inside the forum's main dir and adm/ dirs are win32 specific hacks. You need to remove those files and replace them with symlinks to the "real" file inside include/ directory.

FUDforum Core Developer
Re: 2.7.2 to 2.7.3 upgrade error [message #28702 is a reply to message #28696] Sat, 05 November 2005 18:06 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I don't understand why go through all those hoops in the first place. Why not make it the same way on both platform? That way you would end up with a working system whatever the OS.

That's just my view on things and other things might be dependant on that but anyway...

I fixed it by doing an upgrade here and reuploading the files on the server. :: Shakes Head ::
Re: 2.7.2 to 2.7.3 upgrade error [message #28719 is a reply to message #28662] Sun, 06 November 2005 22:00 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Got another prob...

Trying to create a new forum give me that error message. Creating the category went fine.

(/home/www/kmm672/html/comm_data/include/theme/default/db.inc:73
/home/www/kmm672/html/comm_data/include/forum_adm.inc:175
/home/www/kmm672/html/comm_data/include/forum_adm.inc:73
/home/www/kmm672/html/community/adm/admforum.php:58
) 1044: Access denied for user: 'kmm672(at)127(dot)0(dot)0(dot)1' to database 'usr_kmm672_1'
Query: CREATE UNIQUE INDEX fud26_tv_60_i_t ON fud26_tv_60 (thread_id)
_POST: array ( 'SQ' => '6283bc0f6521fbfdd92bd8eb3f8f9d6f', 'frm_name' => 'Test', 'frm_descr' => 'Test', 'frm_tag_style' => '16', 'frm_passwd_posting' => '0', 'frm_post_passwd' => '', 'frm_moderated' => '2', 'frm_max_attach_size' => '28672', 'frm_max_file_attachments' => '1', 'frm_mod_attach' => '0', 'frm_message_threshold' => '0', 'frm_forum_icon' => '', 'frm_pos' => 'LAST', 'frm_submit' => 'Add Forum', 'cat_id' => '12', 'frm_forum_opt' => 18, )
Server Version: 4.0.15-standard

If it's a SQL perm problem, there's not much I can do... The forum works, people can post and I can modify pretty much everything (at least that I have done as of now).

Ideas, suggestions?
Re: 2.7.2 to 2.7.3 upgrade error [message #28722 is a reply to message #28719] Mon, 07 November 2005 10:37 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Germany
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Make sure that the account being used has CREATE TABLE permissions.

FUDforum Core Developer
Re: 2.7.2 to 2.7.3 upgrade error [message #28732 is a reply to message #28722] Mon, 07 November 2005 16:44 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
How can I create the whole fudforum db if I can't create tables? I can create tables. That's not a problem. I've got several applications that made tables without a problem.

Here's a list of grants I have for all my DBs on my hoster...

Hopefully that will help:

GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, ALTER, LOCK TABLES ON `usr\_kmm672\_1`.* TO 'kmm672'@'localhost' WITH GRANT OPTION
Re: 2.7.2 to 2.7.3 upgrade error [message #28733 is a reply to message #28732] Mon, 07 November 2005 18:13 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Also get an Access Denied error msg when trying to run consistency...

Disabling the forum for the duration of maintenance run
Locking the database for checking
(/home/www/kmm672/html/comm_data/include/theme/default/db.inc:73
/home/www/kmm672/html/comm_data/include/forum_adm.inc:175
/home/www/kmm672/html/community/adm/consist.php:142
) 1044: Access denied for user: 'kmm672(at)127(dot)0(dot)0(dot)1' to database 'usr_kmm672_1'
Query: CREATE UNIQUE INDEX fud26_tv_1_i_t ON fud26_tv_1 (thread_id)
_POST: array ( 'conf' => 'Yes', 'SQ' => 'b03b6a07b2c54c886947f2a645cd045b', )
Server Version: 4.0.15-standard

This is not fun and getting annoying... Sad
Re: 2.7.2 to 2.7.3 upgrade error [message #28755 is a reply to message #28733] Wed, 09 November 2005 18:02 Go to previous messageGo to next message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Any idea?

Anyone? Anyone? Buehler? Wink
Re: 2.7.2 to 2.7.3 upgrade error [message #28789 is a reply to message #28755] Fri, 11 November 2005 09:52 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need INDEX permission.

FUDforum Core Developer
Re: 2.7.2 to 2.7.3 upgrade error [message #28824 is a reply to message #28789] Fri, 11 November 2005 17:29 Go to previous message
MadJack is currently offline  MadJack   Canada
Messages: 19
Registered: November 2005
Location: Qc
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Figured that out yesterday but thanks anyway Smile

Sent an email to hoster... hopefully they will fix it.
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Upgrade advice sought
Next Topic: Blank page after posting
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Tue Dec 11 06:24:15 EST 2018

Total time taken to generate the page: 0.00845 seconds