FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » fresh cvs 2.7.3? install fails due to 666?
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
fresh cvs 2.7.3? install fails due to 666? [message #28913] Thu, 17 November 2005 22:35 Go to next message
aris002 is currently offline  aris002   United Kingdom
Messages: 8
Registered: November 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
First of all, FUD forums maybe is the best product but installation is such a headache...
Ok, I had installed several times FUD2 on my shared host but this time I'm losing patience on sourceforge.net ...

Result on my screen:
You need to chmod the /home/groups/u/up/upp/htdocs/FUD2/install.php file 666 (-rw-rw-rw-), so that the installer can modify itself. This is needed to avoid problems since your PHP installation enforces memory limit setting.


Who made 666 Twisted Evil Smile?

I've done already a lot of combinations... for the file and the directory.
...cvs, different installers and so on.
I can only guess the problem is with php safe mode=off or/and memory limit or...

I've found in the docs so far:

This step applies ONLY to users who's PHP has a memory limit.
	Make sure that the directory the install script is in is either writable by the webserver 
	or that a "fudforum_archive" file exists and is writable by the webserver. The latter 
	applies only to users on servers WITHOUT safe_mode.


What's meant here by the "fudforum_archive"? ...2-7-3.tar.gz or
something else?

Any ideas? Or experience on sf.net?
http://upp.sourceforge.net/PHP/phpinfo.php

Tnx in advance.
Re: fresh cvs 2.7.3? install fails due to 666? [message #28916 is a reply to message #28913] Fri, 18 November 2005 06:50 Go to previous messageGo to next message
aris002 is currently offline  aris002   United Kingdom
Messages: 8
Registered: November 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I've found out that sf.net doesn't allow writeable directories for webservices... and I wrote testpermissions.php where function @is_writeable() returns not 1 but empty. That means I need install.php without the archive appended. But how to get that?
Re: fresh cvs 2.7.3? install fails due to 666? [message #28923 is a reply to message #28916] Fri, 18 November 2005 10:25 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You can open install.php and move all the data following
<?php __HALT_COMPILER(); ?>
in to the fudforum_archive file.


FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: sql_errors
Next Topic: Blank screen after first step
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 10 05:59:58 EST 2018

Total time taken to generate the page: 0.00886 seconds