FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » Registration fails
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
Registration fails [message #29223] Sun, 04 December 2005 19:41 Go to next message
jkletch is currently offline  jkletch   United States
Messages: 4
Registered: December 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I have installed from CVS today and much of the system appears to be working inlcuding adding users and topics, however when self-registering, clicking the 'Register' button results in a blank page.

Apache reports:

[client 65.30.133.155] PHP Notice: Use of undefined constant topics_per_page - assumed 'topics_per_page' in /usr/home/rogic.org/html/forum/theme/default/register.php on line 250, referer: http://www.rogic.org/forum/index.php?t=register&S=0b388e4db6fa86a9ba84f 082b73ac24f&reg_coppa=0
[client 65.30.133.155] PHP Fatal error: SQL Error has occurred, please contact the <a href="mailto:xxxxx@removed_address.org?subject=SQL%20Error">administrator</a> of the forum and have them review the forum's SQL query log in /usr/home/rogic.org/FUDforum/include/core.inc on line 189, referer: http://www.rogic.org/forum/index.php?t=register&S=0b388e4db6fa86a9ba84f 082b73ac24f&reg_coppa=0

And FUD Forum reports:

(/usr/home/rogic.org/html/forum/index.php:76
/usr/home/rogic.org/html/forum/index.php:180
/usr/home/rogic.org/html/forum/theme/default/register.php:252
/usr/home/rogic.org/html/forum/theme/default/register.php:1994
/usr/home/rogic.org/html/forum/index.php:1190
) 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '0 )' at line 1
Query: 0 )
_GET: array ( 't' => 'register', )
_POST: array ( 'reg_login' => 'USERNAME', 'reg_plaintext_passwd' => '123456', 'reg_plaintext_passwd_conf' => '123456', 'reg_email' => 'xxxxx@removed_address.org', 'reg_name' => 'Joe Kletch', 'turing_res' => 'e9f15c6ff20714b0d8c59d1bbfe53090', 'turing_test' => 'JLRS', 'reg_location' => '', 'reg_occupation' => '', 'reg_interests' => '', 'reg_user_image' => '', 'reg_icq' => '', 'reg_aim' => '', 'reg_yahoo' => '', 'reg_msnm' => '', 'reg_jabber' => '', 'reg_home_page' => '', 'b_month' => '', 'b_day' => '', 'b_year' => '', 'reg_gender' => '512', 'reg_bio' => '', 'reg_sig' => '', 'reg_time_zone' => 'America/Menominee', 'reg_ignore_admin' => '0', 'reg_invisible_mode' => '0', 'reg_display_email' => '0', 'reg_notify' => '2', 'reg_pm_notify' => '64', 'reg_notify_method' => '4', 'reg_email_messages' => '16', 'reg_pm_messages' => '32', 'reg_append_sig' => '2048', 'reg_show_sigs' => '4096', 'reg_show_avatars' => '8192', 'reg_show_im' => '16384', 'reg_posts_ppg' => '0', 'reg_topics_per_page' => '40', 'reg_default_view' => '384', 'reg_theme' => '1', 'fud_submit' => 'Register', 'S' => '0b388e4db6fa86a9ba84f082b73ac24f', 'SQ' => '0', 'prev_loaded' => '1', 'mod_id' => '', 'reg_coppa' => '0', )
Server Version: 4.1.7-log
[Referring Page] http://www.rogic.org/forum/index.php?t=register&S=0b388e4db6fa86a9ba84f 082b73ac24f&reg_coppa=0

Some version info:

mountain rogic.org $ php -v
PHP 4.3.10 (cli) (built: Feb 28 2005 11:12:51)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


mountain rogic.org $ mysql -V
mysql Ver 14.7 Distrib 4.1.10, for portbld-freebsd5.3 (i386)

Anything else I can provide?

Thanks!

Joe

Re: Registration fails [message #29232 is a reply to message #29223] Mon, 05 December 2005 10:44 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Did you install from CVS (as in run install.php) or did you just upgrade some files? A new database field was added, which would explain the error you are seeing if you just upgraded some files.

FUDforum Core Developer
Re: Registration fails [message #29235 is a reply to message #29223] Mon, 05 December 2005 10:51 Go to previous messageGo to next message
jkletch is currently offline  jkletch   United States
Messages: 4
Registered: December 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I run the cvs download on the install documentation pages, then ran install.php from the browser. I created a mysql user and empty db before running install.php.

I can redo everything if needed. Please advise.

Thanks!
Re: Registration fails [message #29237 is a reply to message #29235] Mon, 05 December 2005 11:10 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
This patch will fix the problem.
http://cvs.prohost.org/c/index.cgi/FUDforum/chngview?cn=7472


FUDforum Core Developer
Re: Registration fails [message #29240 is a reply to message #29223] Mon, 05 December 2005 11:46 Go to previous messageGo to next message
jkletch is currently offline  jkletch   United States
Messages: 4
Registered: December 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Pardon my ignorance. I edited the file:
FUDforum/src/users_reg.inc.t

Per your patch, however the problem persists. Do I need to go through a reinstall? What is the best pratice for applying this patch?

Thanks for your help!
Re: Registration fails [message #29241 is a reply to message #29240] Mon, 05 December 2005 11:51 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to rebuild the theme.

FUDforum Core Developer
Re: Registration fails [message #29242 is a reply to message #29223] Mon, 05 December 2005 11:55 Go to previous message
jkletch is currently offline  jkletch   United States
Messages: 4
Registered: December 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Excellent that worked. Thank you very mush for your help and support.

Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: user cant edit Profile
Next Topic: Debian Install apt-get
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Mon Dec 10 04:13:13 EST 2018

Total time taken to generate the page: 0.00666 seconds