FUDforum
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » I can't login after upgrade
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
I can't login after upgrade [message #29664] Sun, 08 January 2006 08:27 Go to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hi.

I upgraded from 2.6.1 to 2.7.3. Everything seemed to be working ok, since I could login after upgrade and browse messages (I didn't try to post), but after the cookie expired, I can't login. I've tried deleting the records in the ses table, use and not use cookie, and to directly login from /adm, where I see the new password is right, because if I enter any other, I get "Only administrators with proper access credentials can login via this control panel".

How can I fix this?
Re: I can't login after upgrade [message #29665 is a reply to message #29664] Sun, 08 January 2006 12:12 Go to previous messageGo to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I think it's solved. One thing I had working is that the cookie domain was an alias of the url forum, so I changed the cookie domain to match the url domain. I've also disabled cookies.

But I don't understand why a user I created meanwhile for testing was working, and still works.
Re: I can't login after upgrade [message #29682 is a reply to message #29665] Mon, 09 January 2006 10:20 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
Probably because that user was using URL sessions and as such was not affected by the imporperly set cookie settings.

FUDforum Core Developer
Re: I can't login after upgrade [message #29690 is a reply to message #29664] Mon, 09 January 2006 18:26 Go to previous messageGo to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I think that some kind of check (maybe a setting I'm not aware of) has changed between 2.6.1 and 2.7.3, because it worked that way before (maybe the previous behaviour was buggy and it's been corrected). I cleaned all session and domain cookies in the browser, even restarted, and tried not to check the "use cookies" checkbox, but all failed. Certainly, I was using url sessions for both (the new and the old), unless it's set somewhere I don't know (I'm new to fudforum).

At this time, it's just curiosity, unless there's some hidden bug (or there was before and it's been fixed).
Re: I can't login after upgrade [message #29699 is a reply to message #29690] Mon, 09 January 2006 22:29 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It works fine on my test system here... I'd need to see the forum in question in order to be able to tell you more.

FUDforum Core Developer
Re: I can't login after upgrade [message #29715 is a reply to message #29699] Tue, 10 January 2006 16:10 Go to previous messageGo to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
The url is http://foros.escomposlinux.org/
Re: I can't login after upgrade [message #29728 is a reply to message #29715] Wed, 11 January 2006 09:46 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
You need to check your cookie settings I went to your site and it does not set a cookie as it should.

FUDforum Core Developer
Re: I can't login after upgrade [message #29734 is a reply to message #29728] Thu, 12 January 2006 05:28 Go to previous messageGo to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
What's wrong with it?
Re: I can't login after upgrade [message #29740 is a reply to message #29734] Thu, 12 January 2006 16:33 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I cannot tell without seeing the forum's settings.

FUDforum Core Developer
Re: I can't login after upgrade [message #29742 is a reply to message #29664] Thu, 12 January 2006 17:04 Go to previous messageGo to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
I mean: what do you get and what did you expect to get?
Re: I can't login after upgrade [message #29818 is a reply to message #29742] Tue, 17 January 2006 14:37 Go to previous messageGo to next message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
I expect to see the Set-Cookie header, but there is none.

FUDforum Core Developer
Re: I can't login after upgrade [message #29882 is a reply to message #29818] Mon, 23 January 2006 05:34 Go to previous messageGo to next message
omgs is currently offline  omgs   Spain
Messages: 16
Registered: January 2006
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
The error got reproduced again. I don't know what happened, but I've seen the cookie domain got reverted to the original domain value in globals.php (no idea why). I set it again and I can login.

Surely this has to do with the installation method, because for testing, my initial settings were for that domain, but after the upgrade and some check, I changed manually by editing the files all the ocurrences of the previous domain to the current domain, and though it works now, it looks like it's hashed somewhere and it's restored (I did a consistency check to your request in another post).

What can I do or what do you want me exactly to do?

[Updated on: Mon, 23 January 2006 08:07]

Report message to a moderator

Re: I can't login after upgrade [message #29895 is a reply to message #29882] Mon, 23 January 2006 09:57 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Administrator
Core Developer
add to buddy list
ignore all messages by this user
It sounds to me like you have multiple copies of GLOBALS.php rather having them all be symlinks to the actual config file inside the include/ directory.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: Postgresql pg_hba.conf
Next Topic: Simple question
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Thu Sep 20 22:18:16 EDT 2018

Total time taken to generate the page: 0.00821 seconds