Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » FUDforum » FUDforum Installation Issues » templates fonction
Show: Today's Messages :: Unread Messages :: Show Polls :: Message Navigator
| Subscribe to topic | Bookmark topic 
Switch to threaded view of this topic Create a new topic Submit Reply
templates fonction [message #30174] Thu, 09 February 2006 10:29 Go to next message
pgerald is currently offline  pgerald   France
Messages: 5
Registered: January 2005
Karma: 0
Junior Member
add to buddy list
ignore all messages by this user
Hello, we installed the FUDforum about a year ago, and it has been running well. Many thanks!

However, we have now been asked to make a change which we are finding difficult to put into practice. I wonder if someone has had similar experience and might be able to point us in the right direction...

We customized the templates fairly heavily at the beginning, in order to sober up the display for our targeted user groups. Also, because access to our forum is restricted to particular user groups completely defined in advance, we deleted calls to the templates {TEMPLATE: subscribe_link} and {TEMPLATE: unsubscribe_link}.

Our problem now is that, for a new user group, we have been asked to reinstate these buttons... And every time we try to modify the templates in order to add the buttons, we find there is a call to a variable that is not defined!

For example, we started with the template thead.tmpl and copied over the relevant <td>...</td> from an "original" copy of the forum, installed on another machine. This gave the error: No such tag: IF -> _uid

We then tried to reinstate the part of private_msg_entry that includes ==_uid, but this gave the error that !$all_v was not defined...

Help! Any clues?

Many thanks in advance for any guidance you can offer.

PS An added complication is that the version running is 2.6.6, and the version on the second machine is 2.6.8. Could this be causing the problem?

Re: templates fonction [message #30179 is a reply to message #30174] Thu, 09 February 2006 13:01 Go to previous message
Ilia is currently offline  Ilia   Canada
Messages: 13241
Registered: January 2002
Karma: 0
Senior Member
Core Developer
add to buddy list
ignore all messages by this user
IF tag is only available in FUDforum 2.7.0 or higher.

FUDforum Core Developer
Quick Reply
Formatting Tools:   
  Switch to threaded view of this topic Create a new topic
Previous Topic: new instance - pictures problem
Next Topic: Backup error
Goto Forum:

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ]

Current Time: Fri Mar 23 05:11:52 EDT 2018

Total time taken to generate the page: 0.00626 seconds